Colour Swatches not changing main image

wux
Visitor
1 0 1

We just uploaded a new product. I assigned images to each variant colour, but when on the live front end product page and clicking on the colour swatch, the main image does not change to reflect the appropriate colour. Please advise? 

 

Replies 3 (3)

KetanKumar
Shopify Partner
36822 3634 11960

@wux 

Sorry you are facing this issue, it would be my pleasure to help you.

Welcome to the Shopify community!😊
Thanks for your good question.

Please share your site URL,
I will check out the issue and provide you a solution here.

If helpful then please Like and Accept Solution.
Want to modify or custom changes on store Hire me.
- Feel free to contact me on bamaniyaketan.sky@gmail.com regarding any help
Shopify Partner | Skype : bamaniya.sky
PSD to Shopify | Shopify Design Changes | Shopify Custom Theme Development and Desing | Custom Modifications In to Shopify Theme | SEO & Digital Marketing

Iris
Shopify Staff
810 66 91

Hi @wux ,

 

Thank you for posting this question. 

 

What theme do you use? As others mentioned, it would be great if you could share your store URL so we can check if the same issue happens on our end.

 

If you followed the guide on adding images to variants, there should be no issues. However, some themes include display options for additional product images that disable the image and variant interaction. You check if your theme has this option built in if you head over to Theme Editor and check the settings for the Product page.

 

Also, some apps may influence the behavior of product images. To inspect if any apps in use cause this issue, go to your Apps section within admin. If you find that any apps you have may be interfering with the theme settings, it would be worth contacting the app's developers for further troubleshooting.

 

Finally, the easiest way to determine if the issue is related to the specific theme code and not core admin is to install a new fresh version of the theme and test if you experience the same.

 

Let me know what you find.

Iris | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

Pawvorites
Tourist
3 0 0

Hello, I got this problem twice on the different products and here's what I did:

  1. I cleared the browser's caches: Well this method worked well in my first product, but not in my second product. But, you should still consider doing this.
  2. I changed and rechanged the product's images: If clearing browser's cache didn't work then I suggested you to changed your product variant's image to another image (random as it's different than your first picture), then save it. You must make sure that the Shopify system save the change by exiting the product menu, if Shopify still asks you whether to leave the unsaved change means the system still not saved it and you must redo it until it is saved. After that come back and changes it again to your initial image and save it again, also make sure that the system saves it.

This method came from my trials and errors so there's no scientific or logical explanation XD. But, I have done it and it worked and hope you so 🙂