Domain authentication for sender email

2 0 0

I bought the domain for my store directly from shopify, everything is set correctly and i have a Zoho email to use as a sender email. I already configured the DNS part and it all seems correct, also I can send and receive emails with the Zoho email with no problems at all for examples from Gmail and Outlook. The problem is, I am not able to receive the verification from Shopify to confirm i have access to that email and use it as sender email. I click the button a million times and i receive nothing, also i tried the Contact form from my store and nothing is being sent. So basically anything that is sent from shopify does not really get sent. I contacted both Zoho and Shopify, the problem seems from the Shopify end, something is wrong and they’re looking into it but i received no response and i need ir solved or i will problably claim a refund for the domain since i bought it from Shopify.


one of the staff when they checked the logs, this is what they saw; unable to get mx info: failed to get IPs from PTR record: lookup <nil>: unrecognized address". But the mx info is set correctly, i checked the Zoho and i copied and pasted exactly the records. I also added others records that Shopify specified to add. The problem is with the MX records or the IP of the A record or something, but it’s definitely Shopify since the email works correctly. Also i did not receive any emails in the spam folder and when i asked Zoho they checked the logs and they received nothing from Shopify in their servers, so its blocked in Shopify.



Replies 2 (2)

Shopify Expert
1130 123 285

You have your "sender email" within the "notifications" settings on Shopify set to "" ... but your domain name is "".

So the email should probably be "".


You've entered an email address that doesn't match your domain name. 

★ Did my post help? If yes, then please like and accept solution. ★

Hire me for your Shopify project @ |

2 0 0

I did correct it but still nothing, it’s a typo in the screenshot since i kept changing it… but still not working 😕