Domain SSL Unavailable - And redirect loop

lifson
Tourist
6 0 0

So I've had 2 chat sessions with support spanning about 4 hours since yesterday and have yet to receive a solution. 

I transferred my domain, brokenrobotcoffee.com, in February, and ever since it showed as "setup in progress" and unlike the domains listed in the Shopify managed domains in the section below, there was no visible "manage" link. screenshot of how it looked. For 9 months......

setupinprogress_nolink.png

One issue I'd been having was if you put www before the domain it would error out and not load my site. My understanding is that it should be auto-redirecting to my primary domain, which was without www. However all the solutions I'd seen posted about this issue suggest editing/fixing/resetting dns settings for the domain, but not seeing a manage link, I didn't have access to the dns settings.

While chatting with support, and moving windows around and resizing suddenly a horizontal scroll bar appeared under the primary domain, and low and behold a "manage" link was found! It should be known I'm using an updated and essentially stock version of chrome, so I can't be the only one with this issue. setupinprogress_link.png

So now that I have access to the settings, I reset the dns, reconnect my G Suite for mail, and suddenly its auto-redirecting the way I'd expect it to, from www.brokenrobotcoffee.com to brokenrobotcoffee.com and went from showing "setup in progress" to "SSL unavailable", but within 30 minutes changed to "SSL pending".

Here is where it all falls apart. I have read that for long term growth, and some benefits for seo, using the www version for primary domain holds some advantages. So thinking I've fixed the issues, I changed the primary domain to the www version. It goes back to SSL unavailable, which wasn't a surprise, but when I try to load the site, it throws a "too many redirects" error. I can even see that I'm being bounced back and forth between the www and the naked domain, never loading the site. I tired loading the site on several devices in multiple browers, most of which had never loaded the site before, so please for the love of god don't ask if I cleared my cache and cookies. I look over the settings, decide to try resetting dns again, but this has no effect.

 

Back chatting with support, they confirm its not loading for them either. They check the dns settings and tell me I have two A records and to please delete both and replace with 23.227.38.65

In my dns settings, it only shows one of the two A records that who.is shows, so I tell her I am unable to delete the additional A record. She tries resetting from her end but its not working. I wait about 30 more minutes while shes reaching out for additional support, and she says we will have to move to email support as shes waiting to hear back from Tech support team. That was 2am PST last night, and I haven't gotten anything since. This morning nothing had changed, still SSL unavailable, and the redirect loop of death. I had thought that switching the primary back to the naked domain might at least get it accessible, but I had left it overnight because I wanted support to figure out why it was broken. But not having any response or solution I switched back to non-www version and fixed the redirect loop so it at least became accessible, but there is obviously something wrong, and I should be able to set it to the other domain with creating a redirect loop, and SSL is still unavailable.

 

Sorry for the long post but going through some of these support posts is painful when the first five posts are just back and forth answering basic questions that could have been provided in the initial post. Plus I wanted to provide step by step context incase someone spots where things went wrong. Any help is appreciated.

Replies 2 (2)
lifson
Tourist
6 0 0

Well poking in the dark since support has been completely silent, I just fixed the redirect loop by clicking "connect existing domain" and typing my domain, which has been transferred to shopify since February, and adding it. All of a sudden the problem chat support worked on for nearly 4 hours was fixed. Maybe now SSL will finish setting up.added_domain.PNG

lifson
Tourist
6 0 0

And now SSL is working. Not sure why I had to "connect existing domain" for a domain managed by shopify, but I guess I fixed it.