Failed on business verification in Japan, HELP!

JAPAN_IMO
Visitor
2 0 0

Hi there.

I was asked by Shopify's email to verify my Business Verification yesterday.

Since then I've been submitted my legal government ID and it wouldn't go through.

 

It says "The name on the photo ID doesn’t match the name of the account owner."

However, it is matching.

 

I live in Japan, and I believe due to this reason, the page is also asking for me "Kana" name (name in japanese).

I put my name in english in "First Name" and "Last name" field, then my name in japanese katakana in the "Kana" field. But it got rejected multiple times.

 

It's not making sense because the names are matching my ID (note: my ID only has my english name, not katakana japanese name, as I'm not Japanese national. But my english name is the account owner name across all systems on Shopify)

 

Please help.

They're asking to get this Business verification by tomorrow 10pm. It's 7pm right now.


Thank you so much!

Replies 2 (2)

Victoria
Shopify Staff
2093 148 247

Hi, @JAPAN_IMO.

 

Welcome to the Shopify Community. 

 

I understand you're in the process of submitting your business verification documents for Shopify Payments. You mentioned that you're receiving an error message that The name on the photo ID doesn’t match the name of the account owner

 

When submitting business verification documents for Shopify Payments, the documents must match the information on your Shopify Payments account. The information should be clear, valid, up-to-date, and error-free. We have more information in our Setting up Shopify Payments resource.

 

If you're experiencing issues submitting your documents, I encourage you to create a support request via the Shopify Help Center to get in touch with our team. Additional documents may be requested. 

Victoria | Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

Galli2
Visitor
1 0 0

Im having the same problem, how do you fix this problem?