First Class Mail not showing as an option at checkout

First Class Mail not showing as an option at checkout

Killian13
Visitor
3 0 3

My shop sells a few flat, very lightweight items that fit in an envelope. I've tried setting up a bubble envelope as both an "envelope" and "soft package or satchel" in Shipping & Delivery packages but I can't get Shopify to show USPS First Class Mail as an option at checkout; customers only see Ground Advantage. The option shows in Shopify Shipping so it should be available. Does anyone know how to get this to show? If a customer is purchasing a small $10 item we don't want them being forced to pay almost $5 when they could be paying $2.

 

IMG_7887.jpg

Replies 2 (2)

CycloneFPV
Visitor
3 0 0

Did anyone get a fix to this?

Erin
Shopify Staff
1065 136 171

Hi, @Killian13 and @CycloneFPV. Typically when this happens it's caused by the order not meeting the qualifications for First Class Mail to appear. In order for this option to appear the order must be:

  • A domestic shipment (international shipments are not supported for First Class Mail at this time)
  • 13 oz (0.8125 lb) or less
  • In an envelope larger than 11.5 x 6.1 inches and less than 15 x 12 inches, or in a soft package less than 0.75 inches thick (boxes do not qualify for First Class Mail rates)

If orders do meet these requirements and customers are still seeing 'Ground Advantage' instead of 'First Class Mail' as an option, we'd need to look into this further to determine what's causing it. For more help please contact our support team through the Help Center here. We can't see your shipping or account settings here over the Shopify Community, but if you contact us through the Help Center we can review this with you in more detail.

Erin | Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog