How to remove <mailer@shopify.com> when replying to customers.

Solved
Abdiqani
Tourist
19 0 2

Hello, I hope this finds you well. I have a problem that I need help with. I hope one you guys can help me. When a customer sends a email to me through Contact Us it shows in a weird way. But that is okay with me but when I for example reply directly to the email it shows  the store name then <mailer@shopify.com>. How do I fix that? Your help would be much appreciate it. Here are screenshots. first is How I see it on my email and the second picture I highlighted how the customers sees it. 

 

Screenshot (33).pngScreenshot (34).png

Accepted Solution (1)

Accepted Solutions
Sebastian_Young
Pathfinder
88 4 33

This is an accepted solution.

@Abdiqani You could just remove it from the quoted reply in that case.

View solution in original post

Replies 6 (6)
Greta
Shopify Staff
44 10 8

Hi, @Abdiqani!

Thanks for posting your question, I understand how important it is to ensure your branding is consistent across all areas of your store. I’m happy to help!

You may be eligible to add the Shopify SPF and DKIM records to your third-party domain for your sender email, which means the “mailer@shopify.com” would no longer show on the emails you send your customers.

If you are using a third-party domain (aka, the domain isn’t hosted by Shopify), and if you’re on a paid Shopify plan, you can follow these steps to authenticate the sender email on your store:

  1. From your Shopify admin, go to Settings.
  2. Click Store details.
  3. In the Store contact information section, click Manage next to the Sender email field.
  4. On the Sender email page, click Authenticate.
  5. Follow the instructions to enter the new CNAME records into your third-party domain manager.

* The exception to this would be if you are located in Canada, as Canadian senders aren’t eligible to use DKIM records due to data restriction requirements.

Keep me updated on how this goes!

Greta | Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

Sebastian_Young
Pathfinder
88 4 33

Hi @Abdiqani, this is just the default from address that messages sent via the contact form come from. However, it should have a reply-to address set of the customer's email, so when you respond it should go to the intended recipient.

What @Greta has advised is not related to your problem at all, but it's worth doing anyway from a sending perspective.

Abdiqani
Tourist
19 0 2

Hey when I reply that is what the customer will see

Sebastian_Young
Pathfinder
88 4 33

Hi @Abdiqani, this is the normal and correct behaviour when using the contact form. The email cannot come from the customer's email address because it is like to fail authentication and won't be delivered.

Abdiqani
Tourist
19 0 2

I understand but when I reply I dont want that to show. 

Sebastian_Young
Pathfinder
88 4 33

This is an accepted solution.

@Abdiqani You could just remove it from the quoted reply in that case.

View solution in original post