I want to change the "myshopify.com" displayed in the WeChat Pay application.

I want to change the "myshopify.com" displayed in the WeChat Pay application.

WS21
Shopify Partner
4 0 0

8e057049e817ecfee460dba0a6fa2cc2.jpg

 

Thank you for your help.

 

We are currently implementing WeChat Pay (Nihao Pay) for site payments.

 

When I select WeChat Pay for payment, I am redirected to the WeChat Pay app. At that time, the domain name "myshopify.com" is displayed on the screen.

However, since I have my own domain, I would like to display the original site URL instead of "myshopify.com".

When I contacted the payment agency, they said, "This part cannot be changed on the WeChat Pay side, so please modify it on the Shopify side.

WeChat Pay told me that "shopify set "myshopify.com" in the SecurePay description of the API.

 

Is there any solution to this problem?
Thank you in advance for your confirmation.

Replies 5 (5)

ZenoPageBuilder
Shopify Partner
1052 203 221

Hello @WS21 👋

I think it is because you set up WeChat Pay before setting up your domain.

You can remove WeChat Pay and add it again, I guess it may work.

Zeno Page Builder - Build responsive & SEO-optimized Landing pages, Blog posts, Product pages and more...
Learn more at zenobuilder.com
WS21
Shopify Partner
4 0 0

Thank you for your prompt comment.
Am I understanding "before setting up the domain" correctly as "before setting up the domain in shopify"?
WeChat Pay was added as a payment method in the middle of the process, so we set up the domain before setting up WeChat Pay.
If you have any other ideas, please let me know.

ZenoPageBuilder
Shopify Partner
1052 203 221

I don't have experience with WeChat Pay before. But do you happen to have the WeChat Pay app installed in your Shopify store?

 

If yes, you can check the app settings.

Otherwise, I don't come up with any other ideas at the time.

 

 

Zeno Page Builder - Build responsive & SEO-optimized Landing pages, Blog posts, Product pages and more...
Learn more at zenobuilder.com

syedsumaimaly
Trailblazer
147 16 21

Hi @WS21 

To display your original site URL instead of "myshopify.com" when you select WeChat Pay for payment, you need to change the SecurePay description in the Shopify API.

Here are the steps:

  1. Go to your Shopify admin panel.
  2. Click Apps.
  3. Click Manage private apps.
  4. Click the Create new app button.
  5. In the App name field, enter WeChat Pay.
  6. In the Developer email field, enter your email address.
  7. In the App URL field, enter your shop's domain URL.
  8. In the App permissions section, select the Read and write permission for the Payments section.
  9. Click the Create app button.

Once you have created the app, you will need to get a WeChat Pay merchant ID and API key. You can do this by contacting WeChat Pay support.

Once you have the merchant ID and API key, you can update the SecurePay description in the Shopify API. To do this, follow these steps:

  1. Go to your Shopify admin panel.
  2. Click Apps.
  3. Click Manage private apps.
  4. Click the WeChat Pay app.
  5. Click the Edit app button.
  6. In the SecurePay description field, enter your original site URL.
  7. Click the Save button.

Once you have updated the SecurePay description, you will need to wait for the changes to propagate. This can take up to 24 hours.

 

Try these steps maybe they works.

If I managed to help you then, don't forget to Like it and Mark it as Solutions.

WS21
Shopify Partner
4 0 0

@syedsumaimaly 

Thank you for your detailed explanation.

 

We would like to try the method you described.
However, it will take some time before we can try it out for our convenience.
I will be sure to mark it as a solution with a "like" when it is resolved.


Thank you for your understanding.