Re: My social thumbnail image isn't populating on WhatsApp? Theme Origin.

My social thumbnail image isn't populating on WhatsApp? Theme Origin.

ollyjoshi
Tourist
6 0 3

Hi guys,

I really need a hand figuring out why my social sharing image isn't loading on WhatsApp when the URL is shared. It works fine on Facebook, LinkedIn and Twitter. Just not WhatsApp. It goes to load (with the loading wheel, then disappears). It has almost been 24 hours and it is still the same. 

https://www.malepoli.sh/
 This is my website.

I've used the facebook debugger and rescraped but nothing seems to work. 

Any help would be great! 

Thanks,

 

Olly

Replies 5 (5)

Niki_K
Shopify Partner
450 46 126

Hi @ollyjoshi,

 

not 100% sure that my solution will work but you may give it a try. I assume that Whatsapp does not support images larger than 300px, therefore, you need to change the width and height properties. I would try something like this:

 

<!-- Paste your desired width or height in the place of XXX – needs to be less then 300  -->

<meta property="og:image:width" content="300">
<meta property="og:image:height" content="XXX">

OR

<meta property="og:image:width" content="XXX">
<meta property="og:image:height" content="300">

 

 

You need to make sure that the image ratio still makes sense. Plus, do not forget to test it for other social media platforms if the image isn't too small. And one more thing – test it with the FB sharing debugger or any other debugger. You may need to wait for a while before you see the change.

 

Let me know if this helps?

 

Send me a link to your store to niki@ecommercepot.com and I'll help you out.
For more info what I do, visit my agency website ecommercepot.com or my personal website nikikozak.me.

ollyjoshi
Tourist
6 0 3

I'VE SOLVED THIS.

The file size was too large. I saved the same image out again but a web optimised version that didn't effect quality. Reduced it from 744kb to 150kb and it now works!

Niki_K
Shopify Partner
450 46 126

Great! Thanks for the update and information how you fixed it!

Send me a link to your store to niki@ecommercepot.com and I'll help you out.
For more info what I do, visit my agency website ecommercepot.com or my personal website nikikozak.me.
Chasken
Visitor
1 0 0

Hello Niki, I have the same Problem like Olly. When I upload my Website sharing image it is somehow squezed and i have the right size. I tried your method with with or height on 300 px. But that didnt work out. I tried it with Ollys Method, but that didnt work aswell.  mel-poole-LUPXhXj2ip0-unsplash.pngScreenshot 2023-10-14 232335.png

olivebasics
Visitor
1 0 0

this worked!!!