products didn’t publish to Google

Tradejunction
New Member
1 0 0

My shop contains food products like coffee and chocolates daily needs like that, How do i get MPN fro those items. Thats why every time there is a n error message like 'products didn’t publish to Google' please help me if anyone faced this already.

Replies 6 (6)
Trevor
Community Moderator
Community Moderator
3210 432 739

@Tradejunction 

Pulling from our help document, you should be able to set the product as "custom products" if they do not have  GTIN or MPN. I also found a similar community post here that says you can list these types of products as custom products.  

  1. From your Shopify admin, go to Sales channels > Google.

  2. On the Overview page, go to the Product feed section.

  3. Beside a product status, click the link to view your synced products in a bulk editor.

  4. Click Edit Google fields.

  5. Optional: If your product doesn't have a GTIN or MPN because it's a custom product, then check This is a custom product.

  6. Optional: In the Product categorization section, add a Google Product Category.

  7. Optional: Add custom labels for Age, Gender, or Condition.

  8. Click Save.

Trevor | Community Moderator @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

anagat
New Member
1 0 1

My products are still not publishing. I select that this is a custom product and also fill in the product category however it publishes for a moment and then reverts back. 

Catharina_Coyle
Tourist
7 0 5

I have the exact same problem. Some get through, others don't.

K4B
New Member
1 0 0

I have the same issue.  Were you able to get it resolved?

JilanneDoom
New Member
1 0 0

Same here as far as the other subsequent posters. I've followed all the steps you've laid out – also selling handmade custom goods (jewelry for me) – and these identifiers still don't seem to be enough. I've looked through lots of help guides and followed the instructions. Would love some more detailed instruction.

kikitextile
New Member
1 0 0

I have the same problem, I select that "This is a custom product" , it publishes for a moment and then reverts back. My products are still not publishing.