Solved

products not showing up in collection page

alee-takeon
Visitor
2 0 4

Hi there, brand new to shopify and this is hopefully an easy fix.  I've created manual collections in my store. I've added them to the menu but when I click on them in the preview none of the products are showing up! it says "Sorry, there are no products in this collection"  and I'm not sure why.  They're definitely in there... Any thoughts?  I am using the Jumpstart theme.

Accepted Solution (1)
Ollie
Shopify Staff
2423 454 408

This is an accepted solution.

Hey @EstivalDrip.

 

Thanks for reaching out.

 

We have a blog post that goes into this in more depth Troubleshooting: Products aren't showing up displaying in collection that may be useful.

 

Since this is a 4 year old thread with outdated information, I will be locking this and marking my answer as a solution.

 

If you find our blog post doesn't help resolve your issue, then please feel free to start a new thread in the Shopify Discussions board or contact Shopify Support for further assistance.

Ollie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

View solution in original post

Replies 115 (115)

Lizzy
Shopify Staff (Retired)
469 57 179

Hey, @alee-takeon.

 

Lizzy here, from Shopify.

 

First of all, welcome to Shopify! Starting a new store is always an exciting time, what sort of business are you building?

 

There are a few possible reasons why you're not seeing your products appear. The first would be if you have multiple collections and the incorrect one is linked in the Navigation. You can double check which collection it is under Online Store>Navigation. Then select your menu and the menu item. The information will appear here.

 

29-26-spd9o-p8w0g

 

In this spot, you'll also see the option to filter the collection by tags. Make sure any tags you add in here match up with the tags you have on your products that you want to see. Any products that don't have tags matching what is typed in here won't appear.

 

Another possibility is that your products aren't set to be available in the Online Store. You can check that within the product pages here.

 

29-29-4edza-akhgi

 

Hopefully one of these solves the issue you're seeing, please let me know if you have any questions!

 

Thank you,
Lizzy

To learn more visit the Shopify Help Center or the Community Blog.

Sophie1988
Tourist
6 0 6

Good day,

 

I have the same problem on my website cokoyoga.com . New products dont show up on my collection page on the website. 

In the admin page:

- I checked the collections -> the product shows.

- In the Navigation page -> also shows.

- In the Online store -> already published.

 

This happens like 10 times. Before, I feeel like my products ghosted me. some shows up after 1 day, some never shows up...

So what is my problem please?

Lizzy
Shopify Staff (Retired)
469 57 179

Hey, @Sophie1988.

 

I'm sorry to hear you're also having trouble with your products appearing. If you've gone through all of the possibilities I'd mentioned above, this may be due to how your products are pulled onto your store. It is also odd that they sometimes appear after a period of time.

 

I wanted to confirm with you, what are the steps you go through when adding a product, and then including it in a collection?

 

Thank you!

 

Lizzy

To learn more visit the Shopify Help Center or the Community Blog.

boburhb
Visitor
1 0 8

Hi @Sophie1988.  Sorry for bothering with the same question, but can you have a look Screenshot from 2019-05-29 20-59-18.png

This is my collections and i think everything is right, but look Screenshot from 2019-05-29 21-00-37.png

once i enter my product page and click collections it only shows Home page, i have been strugling with that stuff for 2-3 hours. Please any advice ?

Thank you 

Bobur 

Monipupi
Tourist
3 0 10

I have been looking through all the threads discussing this but nothing worked. Everything should be showing. My Products are published, tagged and I could not get them to show up in the storefront when you click on the submenu link. Funny thing is, one product is indeed showing when I click on the submenu (t-shirts), just the other submenus (sweatshirts and hoodies) don't work. Also the products show on my storefront, just not when you navigate through the menu. I checked the tags so many times. Can you please help me?

Monipupi
Tourist
3 0 10

Oh man, hours later I realized what the mistake was. 

In both collections that were not showing the products there was a condition setup, so actually one tag was missing. Hope this helps somebody.

misick
Visitor
1 0 1

I have done everything in this thread and even added the tag to match the conditions but my products still are not showing in the specific collection. Im not sure what to do!

Monipupi
Tourist
3 0 10
Hey, have you ckecked both the tags in collection conditions as well as the
tags in the navigation? ad you made sure all your products that are missing
have the tag?
artgalstudio
Tourist
5 0 0

I think Monipupi and I were traveling the same collision course! Today, after wasting hours and hours with the same issue (item not showing up in the collection list as well as the Collection title not showing up on the product page) and after checking and re-checking the Auto / Page Title criteria, I sat staring at the product page in defeat. And then, there it was, glaring out from the Product Title ..one little character, a letter "s" ..making a word plural when it's not. So there ya have it, in literally 2 seconds all those hours of frustration came to an end. Just goes to show, the fix can never be too minute.

KoriStyles
Visitor
1 0 0

Wym by that I’m having same trouble 

lealjohn
Visitor
2 0 1

Hi @boburhb I am having the same issue. Did you get an answer or figured a solution yet? Thanks

flick1006
Visitor
1 0 2

Hi Lizzy,

 

I'm currently having the same issue. I was able to add a product last month & add it to a collection. Now I CAN NOT. Nothing has been changed. Why does this happen in Shopify. I can not redo ALL of our collections. Any help would be great. Thanks.

valvesekart
Visitor
2 0 3
Same problem is here. I have checked all the solutions provided in this forum. Still product list come in collection at Shopify admin,but not appearing at online store.
However same products are appearing when we choose all products.
dauphyne
Tourist
3 0 7

Same problem is here.  i set the products to be added manually, i removed conditions.

I have checked all the solutions provided in this forum.

Still product list come in collection at Shopify admin,but not appearing at online store.
However same products are appearing when we choose all products.

leelee123
Visitor
1 0 1

I just solved this go to the individual product listing and on the right side where it says- 

SALES CHANNELS AND APPS make sure to select online store at the moment if nothing is selected it will not be live on your page.

Hope this helps!!

jzjacobs
Visitor
1 0 0

I was quite frustrated by this issue myself. Make sure the product status is not set to "Draft" and instead set it to "Active".

You can verify this by going to "All Products" and sorting by "All", " Active", "Draft", or "Archived". If the products you are trying to see are still in "Draft" they will not populate into your online store.

Activate Products with these easy steps =>

1) Select the products that you would like to activate by checking the boxes next to the product names

2) Select "More actions"

3) Select "Set as Active"

Hope this helps someone out there.

Asialovex
Visitor
2 0 2

Make sure when you go to products that you select all the products you have then. Then press “more actions” and then press “set as active” Maybe your products are not active hun. Hope this help. 

dauphyne
Tourist
3 0 7

Same problem is here.  i set the products to be added manually, i removed conditions.

I have checked all the solutions provided in this forum.

Still product list come in collection at Shopify admin,but not appearing at online store.
However same products are appearing when we choose all products.

- I checked the collections -> the product shows.

- In the Navigation page -> also shows.

- In the Online store -> already published.

Mike_Wibuy
Visitor
2 0 2

Hey -  Any resolution on this? I'm experiencing the same issue. Just added new products and they don't show up in store.


dauphyne
Tourist
3 0 7
I solved it. I my case all my collections are set to add products manually, all are published but only some of the collections were showing. The difference was some of the collections i put TAGS and some no tags. I noticed that all collections which i put TAGS are yhe ones not showing so i removed all tags. And after that it was showing on the website browsing. Im not sure if we have the same case problem. But i hope this eill hel you as well.
BLYR
Visitor
1 0 1

THIS FIXED IT!  100% Saved me a bunch of headaches.  Thank you so much. 

Frekkle
Excursionist
14 0 4

I had to delete my products and the add them again to fix this!  Glitchy!!!!

Nope, nevermind, it worked for a second and now they're not showing up again! WTH!!!!!!?????

adolf
Visitor
1 0 0

Thank you it s work for me

NoraJ
Visitor
2 0 1

This is what worked for with the same problem. I had to go to edit theme and fix the menu and collections there. I put all conditions and then put the name of the collection I wanted it in the tags. Took me forever (hours) to figure this out. It finally worked! I have the Simple theme. Hope this helps someone. 

 

Jax904
Visitor
1 0 1

I was having the same issue and here is how I resolved it.

 

1. Under sales channel, select Themes, and then click customize.

2. On the left menu, select Collections.

3. Click Select, and then select the Collection you want to appear in your collection.

 

You can also drag and drop the order of your collections.  Hope this helps!

shop-cannaqueen
Visitor
1 0 1

Thank you so much! I had tried everything else and this is what I needed!

Wolfe8131
Tourist
4 0 4

I wouldn't say this issue is "Solved..." This glitch is pretty bad... hope it gets fixed.. I went through every solution in this thread and nothing worked.

I added the collection, deleted it. Made active, removed tags, manually added items, did everything twice in different orders. Clicked check boxes to make active. Did everything in threads again in different orders... nothing.. the products wont show up on my collections page...

 

I final followed this one:

1. Check the boxes of the products that are not showing up,

2. Click the drop down "More Actions"

3. Select: "Add Available Channel(s)...

4. This schedules the product to be available in the next 30 mins (WHY SHOPIFY?!)

 

Still doesn't work.... I thought shopify was supposed to help us sell products? but how can I sell product if they wont show up? spent 1/2 day on this issue... 

southairplants
Visitor
1 0 0

Here's what fixed my problem! In your collections, if you have more than one condition, you have to choose "Any Condition" instead of "All Conditions" 

jopie
Visitor
1 0 1

Well its 2022 now and it looks like the issues are still here, did you resolve it? Im going crazy. What a waste of time and money!

dawnjones
Visitor
1 0 0

I am having the same issue.  Has anyone fixed this?

mikea001
Excursionist
34 1 19
Hi dawn,

See KimM’s solution in this thread - remove product from collection and then add it again. Fixed
connieandrick
Visitor
2 0 0
Same issues here has anyone had any help
Janyce
Visitor
2 0 0

I've tried all of the suggestions given previously - and my one of my menu collection just defaults to the main page instead of bringing up the product.   All the other collection options set up previously work just fine.    I'm running the Minimal Template with the Mega Buddah menu app.    I haven't done anything different from previously - 

 

Any ideas or help on this?

MikeRoz
Visitor
1 0 1

I’m having the same problem, products not showing up in collections the way they all have previously. And sometimes a collection show 18 items sometime 20 or as many as it feels like. I know for a fact all my tagging was don’t correctly 

cynthiasboutiqu
Visitor
2 0 1

We cannot figure this out. We have added in every area mentioned and they still will not populate in the collection

 

gigi356
Tourist
4 0 2
I am not having this issue.
godfreyokoye
Visitor
1 0 0

It is not a collection as the items are all different. When I go to my website, the products do not show. I  have to use the search button to look for products. This is very frustrating. Please help me out.

You can also call me on 469-286-6126

MsYolaB68
Visitor
1 0 0

I'm having the same problem. I create the collections but only a few items randomly show up. Everything is in the catalog but not the assigned collection. I don't know how to  fix it. 

Booktides
Tourist
3 0 1

Hi & sorry for the delay. Besides the things already suggested in this discussion, the other fix I discovered was in the product variants. If you name your own variant, that causes problems. It's best to use the given variants. I found 'Style' covers most of my needs.

Besides this, I can suggest not adding tags to the box that pops up regarding collections. Sorry, I can't remember when & where this happens but it's best not to add tags there (though of course do add them within the editing of collections otherwise no products will show up). Hope this helps. If not, do contact Shopify support. They're very good.

chuksbanor
Visitor
2 0 0
Thank you Lizzy, I am new in the business. My problem is that I don't even understand how to set collections. I was able to set navigation but the collection aspect confuses me. Thank your wonderful explanation.
Karzvdb
Visitor
2 0 1

Thanks for the explanation. I have checked all of these things but my products are still not showing up under my collection. I'm not sure why. Is there anything else which could be causing this? 

Booktides
Tourist
3 0 1
Hi Karzvdb. Really sorry to hear that. I can’t think of anything else that
might help myself, except all the usual - making sure the collection
keywords are exactly the same, including same upper/lowercase as on the
listings. Have you been in touch with Shopify? Their online chat is a good
option & I’ve always found them very helpful, even following up with email
afterwards if the issue isn’t resolved. I’d definitely recommend getting in
touch with them. Do hope you can get this sorted out. There’s usually a way
through in the end : )
AizomeMarketing
Visitor
2 0 1

I am having this problem and my product doesn't even show up on my 'all product' page as well as my collection tab. It is labeled as active. Can you help me?

 

DaintyStacey
Visitor
2 0 0

My productss won’t show in my collections page at all. I have  gone to the navigation page but it doesn’t give me the same options to make changes to my menus   As recommended here.   When I select collections I open each collection and there are no products . I have tried to add  products directly from the  all products page and from the collections page- still nothing appears .  

asamad90
Tourist
9 0 2

Hi Lizzy,

I've got a problem similar but on the newly created collection page,  the products in the auto collection type are not appearing down the conditions (filters). especially after installing some collection apps. can you guide me on what to do?

TimothyTrimble
Tourist
5 0 1

I just wanted to add one more step to Lizzy's response. Be patient. When you update the products, it can take a few minutes for the product to appear on the collection pages. I've noticed as long as 10 minutes when updating a lot of products. So, as an overview of things to check:

  • Make sure your Collection Conditions (if there's more than one) is set to Products must match: any condition.
  • Make sure the Product Status for the products is "Active".
  • Make sure the Product Sales Channel includes "Online Store".
  • IMPORTANT! Wait 3-10 minutes for your changes to update before viewing in the Collection Page. 

Once I figured out that last item, all my other frustrations with products showing up went away. You don't need to do an Uncheck and Recheck of the Collection Conditions. You don't need to select the Collection and select "Make Collection Available." All you have to do is check the bullet points above and wait for the changes to kick in. 

nookalabs-dev
Visitor
2 0 0

Hey! I'm having this issue, but none of the "accepted solutions" seem to be an option.

- My Collection has been "up" (but empty) for a few days now

- Items are showing at the backoffice. All good, all active, all available on online store channel.

- Accessing the collection through the URL, no additional filters or tags applied. 

 

Any help would be appreciated. 

PartnersInTrust
Visitor
1 0 0

I was stumped for a little bit why my products was not showing up in my collection.  First I made sure all my products had the same tags as I have in my collection.  I also made sure each product was active, all have the same sale channels. After doing these things my products still was not showing in my collection.  So when I went to my shop and clicked on my collection name nothing still was there.  So I said I know what I am going to go in navigation and delete my coffee mugs collection and re add it to my  navigation.  So when I added it back I went to link and found my collection and then it pop up the collection name and it automatically fill in the name of my collection.  I didn't used any tags for my collection in navigation.  I save it and then went back to my shop and clicked on coffee mug collection and there was all my products for that collection now showing like they should.  I hope I explained this right and it help you. 

Angienjohn97
Visitor
2 0 1

No, it didn't answer my problem. 

I do not know what happened, but the products wouldn't show up with the link to my collection but it did give me a filter option. When I changed the filter option to all products, things came up. Now for some reason it is all gone and the links are not working. When I click on the collection button, it just takes me to the top of my home page again. It wasn't and isn't linked to the homepage. Nothing changed that i know of that should affect this. 

When I use the side menu, it goes to a product page that has no products on it, and even though I've enabled the filter, there isn't a filter. 

The only think I know is that i deleted Debut, because I'm using the Simple Theme. Is that why I lost everything.