'seo hidden' metafield not working properly

Peter590
Visitor
1 0 3

We previously used the 'seo hidden' metafield on our Shopify store to hide certain products from our search field.  Today I added the metafield to some new products, but it was no longer working.

The metafield is:

"namespace" : "seo"
"key" : "hidden"
"value" : 1
"value_type" : "integer"

Has anyone else encountered this issue?

 

Replies 24 (24)

Selig
Tourist
3 0 1

Having the same issue as well, this is an issue with all the existing products that have this meta field as well. We have hundreds of products that were previously hidden, now visible within search. 

Joe47
Shopify Partner
18 0 7

We are seeing the same issue. It happens when a search query ends with a *. Lots of themes add this to search queries and it is causing an issue.

Something on Shopify's end must have changed recently.

justdavenow
Shopify Partner
14 0 4

Same issue started Friday. I've got 3 different sites using 2 different themes and 2 different metafield apps and all 3 are unable to hide products now using metafields.

On Friday support told me they dont have an issue from their side but reading this glad to know it isnt just me.

IonStorm
Excursionist
38 0 3

Has anyone found a solution yet? This is happening on all my sites. Big problem. I have almost as many hidden products as visible products. Why would shopify pull the plug on this without warning? Is there no alternative???

Selig
Tourist
3 0 1

I've been in contact with Shopify, this appears to be an isolated issue with a theme developer. Are you using a Maestrooo theme by chance? 

Try the free Debut theme on as a preview theme and test. 

IonStorm
Excursionist
38 0 3

I'm using one of the Turbo themes. I think @Joe47 is completely right. I noticed when I delete the * from the url search paramter it fixes the issue. I don't know why it matters all of a sudden. It's going to be tough for people are aren't good at coding to fix this.

Joe47
Shopify Partner
18 0 7

This issue is not theme specific, but it is only exposed by themes that add a "*" to the end of search queries. Which is many of them.

The * is added so that your search does not have to match the entire word. This is especially useful if your store has a type ahead search.

For example if you have a product named "Gloves" and someone searches "Glove" without the * you will get no results but if your theme adds the * to make the search "Glove*" you will see the product in your results. If you change your theme to stop adding the * hidden products will not show up again. But this is not an ideal solution.

Shopify definitely changed something in the last couple weeks.

IonStorm
Excursionist
38 0 3

Agree, it was definitely recently. I feel silly that I didn't notice for ~1 week. The look ahead is useful for ajax autocomplete type searches so it might be worth it to keep the * and do another type of filtering during autocomplete. But for normal searches it definitely has to be omitted unless you want embarassing things showing up in search.

@Joe47 btw thanx, you saved me on this

 

justdavenow
Shopify Partner
14 0 4

just to note I have the same issue with the empire theme and supply both made by different developers.

I also notices that the products are hidden when in customize mode but as soon as you view live with a browser all hidden products are displayed.

justdavenow
Shopify Partner
14 0 4

removing the * from search results doent seem to be as easy as it sounds. Does anyone have a few helpful tipson how to remove it as there are so many templates sections and snippets to do with search and the * seems to have a connection to search-sanitizer but having a quick play with the theme and removing the off line doesnt seem to affect the search results for myself.

IonStorm
Excursionist
38 0 3

I downloaded my theme and opened the entire folder using VSCode. Then you can do a folder-wide search for certain text. I just search for anywhere where it said "*" or '*' because most of the things I needed to remove were like this in the case of javascript

searchText = userInput + '*';

Note: I don't mean this specific line of code literally, but it's sorta like that.

justdavenow
Shopify Partner
14 0 4

thanks for the advice. I was hoping I didnt have to mess with the javascripts and was hoping to just alter a section or snippet but it seems Ill have to get stuck in. So far shopify support are blaming theme suppliers and them suppliers are blaming shopify. Got an email Last week from shopify stating you can now use meta fields with the updated frontend API so wonder if this update is the reason the hidden rule is not displaying properly.

Would be nice if they just fixed it instead of having to remove a feature from a paid theme.

Joe47
Shopify Partner
18 0 7

It looks like they fixed the issue. I am no longer seeing the problem on our stores.

Andreavr
Shopify Partner
6 0 1

I'm still having this issue with a superstore theme. Are other's still having issues?

Joe47
Shopify Partner
18 0 7

What store are you having the issue with Andreavr? I can take a look for you if you like.

Andreavr
Shopify Partner
6 0 1

Hi Joe47 - https://www.officefurniturewarehouse.co.nz/products/buro-mentor-arms-upgrade?_pos=1&_sid=64755fe4f&_...  is an example of a product where the 'seo hidden' metafield isn't working any more. If you search for 'upgrade' none of these products should be showing. 

Joe47
Shopify Partner
18 0 7

I don't think that product has the seo hidden metafield set. When the metatag is set Shopify will add the following html tag to the <head> of the page: '<meta name="robots" content="noindex,nofollow">'. Which does not exist on that page. This worked even when the products were showing up in search results.

Andreavr
Shopify Partner
6 0 1

Yes - possibly theme related, that product does have the seo.hidden set to 1 - was working before.
I just added the metafield to another site using turbo and it worked as expected. NOTE: with the new built in shopify 2.0 metafield controls it's a lot easier to setup for a client to hide things. I just made a new Product definition within settings-> metafields -> Product -> name it what you want -> seo.hidden in the namespace.key -> select content type -> number ->integer

Then it shows up at the bottom of the normal product admin area

jam_chan
Shopify Partner
886 23 169

I'm also having the same issue. It was not effective for a user of my app. 

Following this tutorial - hide a resource from search engines and sitemaps, I've added the metafield to the products. But I've changed the value_type to type and integer to number_integer since the value_type deprecated. 

Can someone confirm the issue is fixed now?

BYOB - Build Your Own Bundles, SPO - SEO App to research keywords & edit social link preview
Andreavr
Shopify Partner
6 0 1

I'm still having this issue on that one site. It's using the superstore theme in case that matters.

Andy-Envision
Shopify Partner
12 0 15

We are having this issue with a client and the superstore theme. I had to go in and update all the metafields to the new format (number_integer) which worked for removing the resources from the SERPs (again), but they are still appearing in store search. I just sent the theme devs a message, but were you able to resolve this? 

 

I tried removing the * from the end of the search URL and that doesn't make a difference.  

Francis_Bevan
Shopify Partner
4 0 3

This deprecation might well be the issue, but I am unable to change this when posting metafields via curl. It gets created ok, but with value_type and integer even though I posted type and number_integer. Most odd...

PaladinVinyl
Tourist
9 0 3

Check your newly created seo.hidden products are setup as number/integer. Recently, my newly created ones were all created as text/integer. Not sure why or when it changed. You may need an app to correct current items with the wrong content type. I use Metafields Guru and it is free.

 

Use this link to bulk edit and ensure number is included, change the YourStoreURL to yours:

 

https://YourStoreURL.myshopify.com/admin/bulk?edit=metafields.seo.hidden%3Anumber&resource_name=Product

 

add &query=keyword at end to filter results like this:

 

https://YourStoreURL.myshopify.com/admin/bulk?edit=metafields.seo.hidden%3Anumber&resource_name=Product&query=keyword

 

Good luck, mine works normally again.

Cesar
Shopify Expert
39 1 9

Please note the metafield type is now updated to "number_integer".  You can define this same metafield, by changing the value_type to "number_integer".

 

"namespace" : "seo"
"key" : "hidden"
"value" : 1
"value_type" : "number_integer"

 

Please note that Shopify will add the meta tag "noindex, nofollow" if you turn on this metafield.

Find more about apps for your store.
★ Connected Inventory: https://apps.shopify.com/connected-inventory
We're really good at consulting and customization: enquiry@inscoder.com