Shopify SPF and DKIM Signature

Solved
rlcotejr
Tourist
15 0 2

Hello,

I'm a bit of a novice when it comes to this kind of work, but I've been doing research on why our emails seem to be going to spam more often than not. I used a website: mail-tester.com to test the efficiency of our emails and have come up with the following problems: 

1. [SPF] apparelefx.com does not allow your server 209.85.210.66 to use careers@apparelefx.com (this actually applies to all the emails we have)
2. Your DKIM signature is not valid

These seem to have the biggest impact on our emails. We use shopify for our domain, but use Gsuite as our email provider. 

The smaller problem out of the bunch seems to be our IPv4 has 2 blacklists. Any help on this matter would be great. 

Attached are the results. 

Mail-tester Test.PNG

Blacklist.PNGDKIM.PNGSpam Assasin.PNGDKIM.PNGBlacklist.PNG

Accepted Solutions (2)

Accepted Solutions
Sebastian_Young
Pathfinder
87 4 33

This is an accepted solution.

Hi @rlcotejr,

There are a few things you can do to improve your setup massively. Currently, you don't have an SPF record, so you should create one as follows.

v=spf1 include:_spf.google.com ~all

Do any other services send email on your behalf other than Google and Shopify?

You should also set up DKIM on Google Workspace (formerly G Suite). Follow this link:

https://admin.google.com/ac/apps/gmail/authenticateemail

Finally, you should set up email authentication in Shopify:

https://apparel-efx-llc.myshopify.com/admin/settings/sender-email

Any issues, please let me know and I'll do my best to help you sort it.

View solution in original post

Sebastian_Young
Pathfinder
87 4 33

This is an accepted solution.

Hi @rlcotejr,

Great news that your domain is authenticated on Shopify. That means that bit of setup is good, so is your Google DKIM, now we just need to fix your SPF record.

It is the hostname that is wrong (googleshopifyspf). Change this to @ (literally just the at symbol), save and let me know when done and I'll re-check it for you.

View solution in original post

Replies 8 (8)
Sebastian_Young
Pathfinder
87 4 33

This is an accepted solution.

Hi @rlcotejr,

There are a few things you can do to improve your setup massively. Currently, you don't have an SPF record, so you should create one as follows.

v=spf1 include:_spf.google.com ~all

Do any other services send email on your behalf other than Google and Shopify?

You should also set up DKIM on Google Workspace (formerly G Suite). Follow this link:

https://admin.google.com/ac/apps/gmail/authenticateemail

Finally, you should set up email authentication in Shopify:

https://apparel-efx-llc.myshopify.com/admin/settings/sender-email

Any issues, please let me know and I'll do my best to help you sort it.

View solution in original post

rlcotejr
Tourist
15 0 2

Hello, 

I believe I have done all of the above. I'm a novice at this, so please forgive for if I did anything incorrectly lol. 

For the DKIM portion of instructions, I do recall doing this before but the status remained at: "Authenticating Email" on Google. If this problem persists, what do you recommend? According to Shopify the email is already authenticated. 

Thanks, 

 

Shay
Shopify Staff
513 85 99

Hi @rlcotejr 

Thank you for sharing that health report for your email services. That tool you used is pretty great, definitely adding it to my own toolbox. 

While you have said that you added your TXT record to include the SPF record that @Sebastian_Young shared, I used a couple of different tools and was not able to see that information being output by your domain. How long ago did you update the DNS information? If it was less than 48 hours ago, you may need to wait a bit longer for that to populate. 

You can check the status of those records using a tool like: https://dnschecker.org. If you have added them to your Shopify hosted domain and they are still not outputting after 48 hours you will want to connect with our live support for additional troubleshooting.

Shay | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

Sebastian_Young
Pathfinder
87 4 33

Hi @rlcotejr,

I am seeing your Google DKIM record (google._domainkey.apparelefx.com) but not seeing an SPF record. Could you have another check of this?

Does your domain show as 'authenticated' when you go here?

https://apparel-efx-llc.myshopify.com/admin/settings/sender-email

rlcotejr
Tourist
15 0 2

Hello,

Shopify is showing the domain status as "Authenticated": Authenticated.PNG

I added the SPF the domain DNS settings > Add custom record > TXT record, under the following:

name - googleshopifyspf                                   Points to - v=spf1 include:_spf.google.com ~all

Is this correct? I didn't know what to name it, so gave it a random name. 

Sebastian_Young
Pathfinder
87 4 33

This is an accepted solution.

Hi @rlcotejr,

Great news that your domain is authenticated on Shopify. That means that bit of setup is good, so is your Google DKIM, now we just need to fix your SPF record.

It is the hostname that is wrong (googleshopifyspf). Change this to @ (literally just the at symbol), save and let me know when done and I'll re-check it for you.

View solution in original post

rlcotejr
Tourist
15 0 2

Hello,

Just changed it to @ and it appeared to work! 

Is there anything else you would recommend to optimize our emails? 

Thank you for the help!

Sebastian_Young
Pathfinder
87 4 33

Hi @rlcotejr,

All looking good now!

Sebastian_Young_0-1636394573698.png

Everything should work nicely from this point on.