The chosen fonts for English are not shown in the translated language.

ChristosPhi
Tourist
6 0 3

Hello everyone,

 

I am using the Dawn theme, the updated version 12.0.0, and my site will be published in two languages, the default language is English and the second is Greek.

 

I have chosen two fonts, 'Roboto Slab' for Headings and 'Inter' for Body text. Both fonts are Google fonts and support the Greek alphabet. 

 

The problem is that the chosen fonts work fine in the English pages but they don't work in the Greek one. The Greek pages seem to automatically change to fonts that look like Times New Roman and Arial, for Headings and Body, 

 

What can I do so that my chosen fonts are shown correctly in the Greek pages (and any other language I probably add in the future)?

 

I attach screenshots of both english and greek to see what I mean.

 

Thank you for your help!english.PNGGreek.PNG

Replies 5 (5)
ChristosPhi
Tourist
6 0 3

Hi David,

 

Thanks for your message. I'll give you some details below: 

  • I use Dawn theme, v.12.0.0.
  • The default language in my shop is English.
  • For the translation from English to Greek, I used the Translate & Adapt app.
  • From the admin page, I go to Customize and then from Settings, I go to Typography. Then I choose Roboto Slab for Headings and Inter for Body text.
  • I have previously checked with Google Fonts, if my chosen fonts suppor Greek alphabet. They both do.
  • Finally, save and publish.
  • I have checked my shop in Chrome, Brave, Firefox and Edge browsers of different computers (all using windows 10) and in all of them the fonts are displayed incorrectly.
  • When I open my shop's page in Greek, in Chrome, and I right click to see 'Inspect', the 'inspected' font incorrectly says that is Inter, as the displayed one is clearly another font, probably arial (see attached screenshot). The same happens with Roboto Slab, which is displayed as (most probably) Times New Roman.

I don't know if I have helped with those details. Any idea how to solve this?

 

Thanks a lot!

 

Greek_2.PNG

nestly
Excursionist
13 0 3

Please tell me that you managed to solve that, I have this problem right now.

ChristosPhi
Tourist
6 0 3

Hello there!

Yes, I solved it. 

After a lot of messages with Shopify Support, no solution was given and was told to wait until Shopify solves this issue in a future update.

I insisted, and a I was advised to download the app FONTIFY. I downloaded it and everything was fixed. Fontify's support team is very quick and responsive and it is completely free. 

I hope it works for you too. 

nestly
Excursionist
13 0 3

Thank you it actually worked!!
for those who might land here

  1. Download FONTIFY [free] 
  2. Enable the app and click save
  3. choose font
  4. choose "All (body tags)"
  5. choose the language you want to translate [the foreign lang/ second lang] 
  6. click save

Thank you for helping me, hope it will find others who might be stumble on this

ChristosPhi
Tourist
6 0 3

I am glad it also worked for you! 

Regards.