FROM CACHE - en_header

URGENT HELP. My website is blocked

New Member
1 0 0

I tried to access my website this morning:
I found the following message on the home page:

Private content, please login to show or create an account.

When I click on the login link, it takes me to a url that is absolutely unknown to me.

Has anyone had something similar happen to them?
Could it be an external attack?

I need urgent help.

Replies 3 (3)
Community Moderator
Community Moderator
3223 436 753


What you're seeing on your homepage would have needed to be hardcoded into the theme. It could have been implemented by someone you hired to make changes to the theme or possibly through an app. In either case, you'll need to edit the coding of the theme to have this removed. 

You'll likely find this coding in the theme.liquid file by going to Online Store/Themes/Actions/Edit Code. You can also see if you can revert any changes made to this file by clicking "older versions" - Alternatively, if you have a backup copy of your theme, then you can upload the theme to your themes section and publish the backup copy. 

If you're unsure of how to remove the changes made to your homepage, then you'll need to hire a Shopify Expert if someone from the community is unable to provide insight into how to remove the login request. 

Trevor | Community Moderator @ Shopify (Out of Office until Sept 7th)
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

New Member
3 0 0

I noticed the same thing after adding to cart. I'm wondering if it's caused by some plugin? We're trying to access the situation now.

New Member
3 0 0

Okay I figured it out. For some strange reason, an APP we use developed by bsscommerce, recently bugged out. It created a force login rule and enabled it completely on it's own. Thus the private content and login message. The message "Private content, please login to show or create an account." with URL is their default message when you create a private login page. I had to disable the app/all rules for it to return to normal. Hope this helps.