Solved

Why are my hreflang tags showing errors on SEMRush?

SDog
Tourist
6 0 1

Hi,

 

I have recently added international versions of my store in Shopify with the understanding that Shopify automatically creates the hreflang tags.

 

When running a site audit use SEMRush I am told that I have incorrect hreflang links on my site. There seem to be 6 pages with incorrect links for each international version of my website. These pages are the following: 

 

Account Login

Account Register

Cart

Privacy policy

Shipping policy

Search 

 

Any thoughts on a solution are appreciated.

 

SDog

Accepted Solution (1)

GemPages
Shopify Partner
5589 1261 1218

This is an accepted solution.

Hello @SDog
I would like to give you some recommendations to support you

Regarding your question, you need to add hreflang tags manually inside your HTML headers,
The hreflang code snippet you’ll need to paste in will depend on what languages/regions you’re serving and your page URLs, but it should look something like this:

<link rel="alternate" href="https://www.examplesite.com/" hreflang="en" />
<link rel="alternate" href="https://www.examplesite.com/en-gb/" hreflang="en-gb" />
<link rel="alternate" href="https://www.examplesite.com/en-us/" hreflang="en-us" />


To paste the code you can follow these steps:
1. Go to Online Store->Theme->Edit code
2. Open your theme.liquid file, paste the below code in <head> </head> :
2. Press "Save"

Hope my recommendation can works and support for you!
Kind & Best regards!
GemPages Support Team

GemPages - Build any high-converting store pages for any business


- If you find my reply helpful, please hit Like and Mark as Solution
- Get connected: App Store | Blog | Community | Help Center

View solution in original post

Replies 5 (5)

GemPages
Shopify Partner
5589 1261 1218

This is an accepted solution.

Hello @SDog
I would like to give you some recommendations to support you

Regarding your question, you need to add hreflang tags manually inside your HTML headers,
The hreflang code snippet you’ll need to paste in will depend on what languages/regions you’re serving and your page URLs, but it should look something like this:

<link rel="alternate" href="https://www.examplesite.com/" hreflang="en" />
<link rel="alternate" href="https://www.examplesite.com/en-gb/" hreflang="en-gb" />
<link rel="alternate" href="https://www.examplesite.com/en-us/" hreflang="en-us" />


To paste the code you can follow these steps:
1. Go to Online Store->Theme->Edit code
2. Open your theme.liquid file, paste the below code in <head> </head> :
2. Press "Save"

Hope my recommendation can works and support for you!
Kind & Best regards!
GemPages Support Team

GemPages - Build any high-converting store pages for any business


- If you find my reply helpful, please hit Like and Mark as Solution
- Get connected: App Store | Blog | Community | Help Center
SDog
Tourist
6 0 1

Thank you for the help.

 

GemPages
Shopify Partner
5589 1261 1218

Hi @SDog,

 

I am so glad that my recommendation can help 😁.

GemPages - Build any high-converting store pages for any business


- If you find my reply helpful, please hit Like and Mark as Solution
- Get connected: App Store | Blog | Community | Help Center
Zuzana29
Shopify Partner
5 0 0

Hi @GemPages , I have the same or similar problem to what was described above. 

I also get the same error in Semrush for the same pages listed above, but when I look into the source code of the pages, I already can see that there are the correct hreflangs in the <head> </head>

Anyway, I tried your solution but then I ended up with "double hreflang tags" error. 

I wonder why Semrush is flagging these as errors for me...

Could you help? 🙂

 

Example of the hreflangs on the register page I already have in place:

<link rel="alternate" hreflang="x-default" href="https://mywebsite.com/account/register">
<link rel="alternate" hreflang="en-DK" href="https://mywebsite.com/account/register">
<link rel="alternate" hreflang="da-DK" href="https://mywebsite.com/da/account/register">
<link rel="alternate" hreflang="de-DK" href="https://mywebsite.com/de/account/register">
<link rel="alternate" hreflang="es-DK" href="https://mywebsite.com/es/account/register">
<link rel="alternate" hreflang="fr-DK" href="https://mywebsite.com/fr/account/register">

Thank you for your time!

TrueDealsClub
Excursionist
19 0 3

Hi, My name is Gaby. I experienced a similar issue and now I want my website to only display in English. Could you guide me on what steps I need to take to remove any configurations causing errors related to language settings in the Symmetry theme?

Thank you for your assistance!

Best regards,
Gaby