Delivery customization private access tokens throwing 401

nomad-developer
Shopify Partner
6 0 0

I've created an app that has a customization delivery extension (a shopify function) and installed it in my store. This function hides rates if a condition is met. I installed it and it worked fine. Then, I was editing my code in the main-cart-items.liquid file so that it would overwrite the commune input in the checkout. For this I excecute /cart?checkout url. After a few minutes, the delivery rates stopped appearing in the shipping section of the checkout, and the console throws 401 on the request https://my-url.myshopify.com/private_access_tokens?id=**&checkout_type=*. 
I reviewed the documentation of the shopify functions and my intuition is that it is a problem of the tokens of my application, but I have configured the online tokens with AppBridgeProvider, which I understand this is responsible for refreshing the tokens for each request that is made, so it should not throw error.
Also, I don't know if the error has to do with the call of /cart?checkout, because after a while of executing this, it started to fail.

Here I leave an image of the error.
Captura de Pantalla 2023-04-28 a la(s) 15.22.44.png

 

Is there anyone who knows what could be happening? I would appreciate the help.

Replies 4 (4)

Nick_Wesselman
Shopify Staff
123 31 50

This looks unrelated to the function itself, as the function doesn't require any tokens from your app. Are you still encountering this issue?

Nick Wesselman | Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

nomad-developer
Shopify Partner
6 0 0

No, I decided to uninstall and recreate the application and the problem was fixed. Thanks!

webymaster
Shopify Partner
3 0 0

I am getting the same error as well, I am trying to update the shipping address. I tried to uninstall and install it, but I failed.

webymaster_0-1705001998555.png

 

Amanraj007
Shopify Partner
1 0 0

hey, did you get the solution for this , i am facing the same issue