DAWN 12 Translate & Adapt doesn't translate product metafield in Default

seafoamgreen
New Member
8 0 0

Hello!

I am using DAWN version 12.

I have 2 markets: "France" (my main market, in French), and a region I created called "English EU" (other EU countries, in English).

I created some product metafields in Rich Text in French.

I added the different descriptions in each product in Admin in their respective metafields.

I then assigned each product their corresponding template in Admin.

Then, in the Theme Editor,  I went to my "Default" market, went to the product, and added the product metafields to each product.

However, when I go to Shopify's Translate & Adapt section to translate from "Global French" to "Global English", it doesn't translate the metafield to English. 

 

My store settings are set to:

FRANCE market = French (main site)

EU ENGLISH market = English (en-eu url extension)

 

In the Theme Editor:

The "Default" Editor is in French

The "France Editor is in French

The "EU English" Editor is in English.

 

Can someone please help??

 

Replies 5 (5)

richbrown_staff
Shopify Staff
632 91 154

Hi @seafoamgreen, a few things going on here.

Some products are working ok. For example, this one 1):

richbrown_staff_0-1699393562103.jpeg

 

Whereas this one is not 2):

richbrown_staff_1-1699393577665.png

For product 1) you have added text to the metafields in your admin (/products/8273002594570). So this can be translated into English, and has been.

For product 2), if the country is set to France, you'll see content like:

PLU recyclé.

LED en fonction d'energie solaire.

However if you change the country to one other than France on the store, you'll see it's blank. The reason is that in your France market, in the theme editor, you have entered text into your default product template. This will be used across your products by default. What I think you want to do here is connect the text to the relevant dynamic source, so that it can be different per product. 

 

You also have a mix of English and French in your product descriptions, e.g. for product 2) above. This will confuse the auto-translation system and not work.

 

Lastly in places there is content adapted by market, but not translated. Adapting content by market is for when you want to have different content in different markets, in the same language. For example, you'd want 'color' in the USA and 'colour' in the UK. Translation would be the first step, though. You'll see the relevant warning at /apps/translate-and-adapt/localize/product?shopLocale=en&id=8300040290570&market=eu

 

I hope that helps. Steps:

  • In the theme editor, clear the content you have in the product benefits (ÉCO-CONCEPTION etc) and connect it to a dynamic source. Specifically you don't want the France overrides in there.
  • Make sure your products themselves have these metafields filled in your default language French
  • Then translate into English
  • Remove any adapt by market content unless you're sure that's what you want (two different versions of English)

To learn more visit the Shopify Help Center or the Community Blog.

seafoamgreen
New Member
8 0 0

Hi thanks for your advises!

I cleared all content in the Theme Editor's product templates.

There's still issues though: can you please have a look just at the water bottle and the composter ?

I have linked their respective metafields content in French to their product in "Default".
In Translate & Adapt I went to Products, and in each of these products I have translated the french content to english in  "English (Translate across markets)". I didn't touch "Adapt a market" and left the "EU English" and "France" markets blank.


When I visit my site externally, here is what renders:

 

For the main french/France version:

  • water bottle: all collapsible row content is missing
  • composter: only the first 2 collapsible rows show the metafield content, the rest are missing the content

For the EU English version (anywhere else besides France):

  • water bottle: collapsible rows show all content perfectly in English
  • composter: shows old content information in English that I have deleted from all places. Definitely not the translation of the current metafield.

What could be causing this?

I can send you my password through private message.

 

Thanks again!

 

richbrown_staff
Shopify Staff
632 91 154

Hey @seafoamgreen , ok this is what's happening:

 

For the main/French version of the site, the reason you're not seeing the metafields is that in the Online Store Editor, at some point, you made some edits to the default product template for France. That is what the half green diamonds mean here on the left:

 

Screenshot 2023-11-18 at 21.16.50.png

 

This means that these blocks are overridden for France. And they're overridden with blank boxes. Which why they don't work in France, but do work in, for example, Austria - because that's your EU market, which doesn't have market overrides. This feature is used to branch off different storefronts for different markets, which I don't think is what you want to do here.

 

You'll want to reset them to default. Which then means that the  'Default' values will show (i.e not France specific ones). The dynamic content (your metafields) will then show. Click this:

 

richbrown_staff_0-1700342437715.png

everywhere you want to remove the overrides. You'll also need to do this on 'product with variants' template. That's the reason different things show between the water bottle and the composter - they use different templates. Also for the Eco Teddy Bear you haven't filled in the metafields on the product page.

 

The reason in your EU market the composter shows old content information in English is because it's saved as custom market content for English in your EU market. See here:

 

/admin/apps/translate-and-adapt/localize/online_store_theme_json_template?themeId=144584540426&shopLocale=en&market=eu&id=product.product-with-variant

 

So to get things back in shape:

- Delete market overrides in the online store editor. Find the green diamonds on all the templates and reset them to default

- Make sure your product metafields are all filled in in French, and all connected in the online store editor 'Default' context

- Delete custom market content. The easiest way to find it all is to export your languages CSV - Settings > Languages > Export, and then look in column E for any content that has your EU English market, then just delete it in column H. The reason to do this is so that the custom market content isn't overwriting translations. Things should work in that order, translate first - and only adapt market content if you want that language to be different in different markets.

- Run auto-translation for English with Translate & Adapt. You can then manually check / edit translations in the app.

 

Hope that helps, you should then be back up and running.

 

Rich

 

 

 

 

 

 

To learn more visit the Shopify Help Center or the Community Blog.

seafoamgreen
New Member
8 0 0

Could you please tell me how/where to send you a private message with my site pw?

 

Thanks!!

richbrown_staff
Shopify Staff
632 91 154

Hi @seafoamgreen , we'll take a look at this today

To learn more visit the Shopify Help Center or the Community Blog.