The pop up says that the language is set up in english

ramen-master
Visitor
2 0 0

Hello,

 

I built my website in English but my primary market is France. The problem is, everytime someone from France visits the website, the pop-up says that the language is set to English. Even if the user click 'x' for cancel, the website language changes automatically in English. It is a pain for the user experience.This is the pop-up :

ramenmaster_0-1690809565291.png

 

France is the primary market, thus I want to use the primary domain in 'french' with extension /en for the english version for vistors from France.

 

As i said before, I built the website in English and I translate it in french. So in the settings in Translate and Adapt app, English is the 'default' language and french is a 'published' language.



What are the settings so that :
1) Visitors in France will visit the primary domain in French. 
2) They can change to english so the URL for the English version will be ex : com/en/
3) How to get rid of the pop-up
4) If I can't get rid of the pop-up, what can I do so that the pop will show 'Your language is set to French' (in french of course).

Thank you in advance for your

 

Replies 2 (2)

ramen-master
Visitor
2 0 0

these are my settings :

1) In the 'Market' settings :

ramenmaster_0-1690809832287.png

 

2) In translate and adapt settings :

ramenmaster_1-1690809867944.png

 

richbrown_staff
Shopify Staff
625 90 153

Hi @ramen-master , this the Geolocation app. It detects the browser language, and offers the language recommendation based on that. Nothing is inferred from the country. So the people seeing this pop up are people with their browser set to English. As French is the default language for your primary market, France, anyone landing on international-ramen-club.com whose browser is set to English will see this pop up. You can turn recommendations off in then Geolocation app if you don't want it to show at all.

To learn more visit the Shopify Help Center or the Community Blog.