Solved

About to launch my migrated website and SPEED is really BAD

YdavidPS
Excursionist
16 0 0

Hi

I am hopping to launch my two migrated website by the end of the week but speed is very slow.

hope someone can help me since my developers who developed the website are not managing this task successfully.


My current URL is https://primestyle-new.myshopify.com

 

Thanks in advance

Accepted Solution (1)

Sim_
Shopify Partner
81 9 19

This is an accepted solution.

Hi, 

After evaluating carefully, I found that images are well optimized and loads pretty fast except 2 of them. Also, the document shows up before loading the stylesheet, which give poor first impression to the users. Here are some of the main reasons which make the site slow - 

1. Index page makes almost 670 requests to the server for LCP( Largest Contentful Paint) which makes TTI (Time To Interaction) above 26 seconds and results in very low performance score.

2. Theme has lazysizes library but doesn't use it to defer loading offscreen media( images, videos).

3. Some of the apps which might installed in the past now fail with status code 400, those script tags needs to be deleted.

Hope, this will help.

Thank you.

If helpful then please Like and Accept Solution.
Do you need custom changes or want to boost site speed ? Hire me.
Feel free to Contact me on simranjeetsingh6076@gmail.com

 

 

 

Sim
Shopify Developer & Solutions Expert

View solution in original post

Replies 2 (2)

Sim_
Shopify Partner
81 9 19

This is an accepted solution.

Hi, 

After evaluating carefully, I found that images are well optimized and loads pretty fast except 2 of them. Also, the document shows up before loading the stylesheet, which give poor first impression to the users. Here are some of the main reasons which make the site slow - 

1. Index page makes almost 670 requests to the server for LCP( Largest Contentful Paint) which makes TTI (Time To Interaction) above 26 seconds and results in very low performance score.

2. Theme has lazysizes library but doesn't use it to defer loading offscreen media( images, videos).

3. Some of the apps which might installed in the past now fail with status code 400, those script tags needs to be deleted.

Hope, this will help.

Thank you.

If helpful then please Like and Accept Solution.
Do you need custom changes or want to boost site speed ? Hire me.
Feel free to Contact me on simranjeetsingh6076@gmail.com

 

 

 

Sim
Shopify Developer & Solutions Expert

Farady_G
Visitor
1 0 0

This is very helpful. Here is my site miscof.com. I am also facing this issue.