Blank FCP after i optimized my page speed

aneeshgusain
Shopify Partner
2 0 1

Blank FCP: I optimized my page speed but it led to an issue that made my theme thumbnail to look blank here.
Does anyone have solution to this?

theme.png

Replies 2 (2)

flareAI
Shopify Partner
2405 223 540

Hello @aneeshgusain,


Greetings! I am Gina from the flareAI app helping Shopify merchants get $7Million+ in sales from Google Search, on autopilot.


It seems that you've encountered an issue within your Shopify store. Your attempts to improve page speed have apparently led to a situation where the theme thumbnails are not displaying as intended. While this can understandably lead to frustration, there are steps you can take to analyze and address the issue. Here's a general guide to help you navigate this problem.


-> Verify your theme settings to confirm whether the thumbnails have been inadvertently disabled or concealed. Occasionally, optimization procedures can impact these settings.


-> At times, display problems can stem from browser cache. To investigate, ensure you clear your browser's cache and cookies to determine if this rectifies the issue.


-> Ensure your theme is up to date. Outdated themes can occasionally encounter compatibility problems with newer versions of Shopify or other applications.


-> In the event that you've recently edited your theme code as part of the page speed optimization process, it's wise to review these alterations. Even minor code errors can lead to unexpected glitches. Revert any recent changes and monitor if this action resolves the problem.


-> If your Shopify store incorporates third-party apps, conflicts with your optimization work might be a possibility. Deactivate any recently added apps to check if this resolves the issue.


-> For images optimized during your page speed enhancement efforts, ensure that the optimization process hasn't unintentionally affected the thumbnails. Confirm the correctness of image file paths and formats.


-> Certain strategies to boost page speed involve postponing or minimizing JavaScript files. Should you have edited your JavaScript files, inspect the console for any errors that might be affecting thumbnail display.


-> If you can't identify the specific cause of the issue, consider reverting the changes you made during the page speed optimization process one by one. This will help you pinpoint the exact change that caused the problem.


-> If you've tried the above steps and are still experiencing the issue, it might be a good idea to reach out to Shopify's customer support. They can provide more specific assistance and guidance based on the details of your store and the theme you're using


I trust this will be of benefit to you. If you find the answer helpful give it a Like and ✓ Mark it as an Accepted Solution.

 

Gina

flareAI : Get Sales from Google Search, on Autopilot
$10+ billion in eCommerce on Google Search, every day. Find out how much you are missing
aneeshgusain
Shopify Partner
2 0 1

 

aneeshgusain_1-1693655815384.png

I somehow managed to show the header and first section .
But now the problem is, the hero banner image is still not visible in the thumbnail.
Seems like something is delaying the image's load.
I added loading=eager but still doestn work.
Please provide a solution if you know.
Thanks in advance.