403 (ShopifyCLI::API::APIRequestForbiddenError)

SheDevs
Visitor
2 0 0

Windows 10 Pro: Fully up to date. Using powershell.

 

 

➜ ruby --version
ruby 2.7.5p203 (2021-11-24 revision f69aeb8314) [x64-mingw32]

➜ shopify version
2.13.0

 

 

This old thing again. I see there is another post about this. My scenario is not the same.

I am experiencing this with every new account and partner org I set up. Right out of the gate. It has never worked for me. I am using the following commands in this order to troubleshoot or recreate the issue:

 

shopify logout

shopify login --store lynn-dev-1

I authorize successfully through the web page

I choose the one and only partner organization I have with this account. It's fine I close the page as instructed.

shopify whoami. Everything looks great

shopify theme pull

 

I get:

 

➜ shopify theme pull
X An unexpected error occured.
        To submit an issue include the stack trace.

? Send an anonymized error report to Shopify? (Navigate up with 'k' and down with 'j', press? Send an anonymized error report to Shopify? (You chose: Yes, send)

 

Then i get the stack trace. This is the condensed version:

 

C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/shopify-cli-2.13.0/lib/shopify_cli/api.rb:74:in `block in request': 403 (ShopifyCLI::API::APIRequestForbiddenError)
{"errors":"Unauthorized Access"}

 

 

I can include this entire dump if neccessarry.

 

Am I alone in having trouble getting shopify set up for development? I have tried this on my linux machines as well. This is a fresh install of windows with ruby 2.7 node npm all up to date and in order.

 

I am a bit frustrated.

 

Lynn

 

 

 

Replies 0 (0)