Add to Cart not working on first click

Domondios
New Member
3 0 0

Hi All,

This problem I'm having is becoming a real pain for me. For the life of me, I can't figure out why when I open the Product View Page for any product, and I click on the Add to Cart button, it just doesn't do anything. The moment I click away on the same page and then click Add to Cart again, then it works.

To me, it seems as if when the page loads, it's already focussed on the control and needs to lose focus before being responsive.

I'm new to Liquid and Style Sheet Scripting, so as much as I can tell, there isn't much jumping out at me. The Add to Cart works perfectly... first time... across the rest of the site though.

I'm almost certain it's the script on the product-info.liquid file, but can't be certain. I'm happy to provide any of my scripts if need be?

Please can I get an urgent answer as this is really starting to cause concern and unnecessary pressure from the business?

Even though just clicking away and back again works, some users are lost when it never works the first time.

Thanks so much,

Replies 4 (4)
zypherindigo
New Member
2 0 0

Hi, I am Zypher here to help you today!

Could you share your site URL, if possible, so I can come up with a perfect solution for it?

Domondios
New Member
3 0 0

Hi, Thanks so much for responding.

Listed are my site URL's:

Let me know if this suffices?

Can't wait to find out why the site is doing what it's doing.

Regards,

LitExtension
Shopify Partner
1954 323 394

Hi @Domondios,

I tested and it worked fine: https://imgur.com/a/4wx7PEQ

Have you tested it on another device?

LitExtension - #1 Shopping Cart Migration Expert
If our answer is helpful then please accept as solution!
Are you looking for a solution to migrate to Shopify? Contact us for further assistance.
Try our FREE DEMO now!
Domondios
New Member
3 0 0

Hi,

Thanks for checking it out and you were testing the correct product too.

A number of different mobile/laptop/browsers have been used to test. The problem seems intermittent because across most devices the Add to Cart click works fine.

A few tests were done where the product page was opened and the Add to Cart was clicked almost immediately and didn't respond. Could this be a page load speed issue? I have checked out the performance stats of the site too which has exposed a number of ways where we can remove unused scripts/functions etc. to increase response time.

We're utilizing the Live Theme, so not certain whether anything else theme-related would play a part when it comes to generic liquid scripting.

Thank You