FROM CACHE - en_header

Brooklyn Theme - Slideshow stops on 2nd image...

iPaddy
New Member
13 0 0

HELP !

Hello,

Does everyone have this issue with the Brooklyn Theme?

It does not cycle past the second image. 1st image fine, 2nd image fine, then nothing, nothing happens unless I manually scroll the images myself or reload the page.

Replies 18 (18)
iPaddy
New Member
13 0 0
iPaddy
New Member
13 0 0
joeeverett
Shopify Partner
18 4 5

hi Ipaddy

 

If you give me your store details I'll try and fix it for you.

 

Kind regards

 

Joe Everett.

Waifu
New Member
1 0 0
Hi! I have the same problem. Third image shows after about 15 seconds, sometimes it does not. Were you able to solve this issue? Can you share it with me? Many thanks!
Siamesekrazy
Excursionist
11 0 4
Having the same problem...
beannie
Tourist
5 0 2

I am having the same problem. I have three slides, set to 3 seconds, auto - it will move to the second one and then stop. Help!

Siamesekrazy
Excursionist
11 0 4

Same problem. I tried the fixes suggested by other discussions about this, but they did not work.

Artzen_tech
Shopify Partner
50 12 17

Hi, i have fix this issue with just applying 2 things into my slider code.

you have disable these 2 options in slide

pauseOnHover: false,
pauseOnFocus: false,

After adding this all is set! I hope it will help you all.

If you are not getting it properly let me know!
Thanks!
 

If helpful, please Like and Accept this Solution to help others
Artzen Technologies | A Shopify Development Agency
WhatsApp - 9877983930
Epyone
Tourist
3 0 1

Whats the full name of the "slider code". I can't find the right file in my code. Also where in that file did you put those two lines?

Epyone
Tourist
3 0 1

@Artzen_tech  where do you change:

pauseOnHover: false,

 

In what folder and what line can we find this?

Thanks!

Artzen_tech
Shopify Partner
50 12 17
Hi you have to add it on theme.js.liquid file. Inside hero slider options. Thanks!
If helpful, please Like and Accept this Solution to help others
Artzen Technologies | A Shopify Development Agency
WhatsApp - 9877983930
Artzen_tech
Shopify Partner
50 12 17

In the "theme.js.liquid" file under hero slider options

If helpful, please Like and Accept this Solution to help others
Artzen Technologies | A Shopify Development Agency
WhatsApp - 9877983930
jaeyow
New Member
1 0 2

I can confirm that setting these 2 options to false worked for me. 

Natachajohn
New Member
1 0 0

Can you tell me how to find the hero slider options as I have about 4000 lines of code in theme.js.liquid?

Thanks

WOLFBKS
Tourist
12 0 0

@Natachajohn 

Go to theme.js.liquid

Press Cmd+F (on Mac) or Ctrl+F (on Windows) and enter this.settings

You'll find a piece of code that looks something like this:

 

 

this.settings = {
$element: $slider,
accessibility: true,
adaptHeight: $slider.data('adapt'),
arrows: true,
dots: true,

 

 

Add the two lines in the list of settings, 

pauseOnHover: false,
pauseOnFocus: false,

 

 

this.settings = {
$element: $slider,
accessibility: true,
adaptHeight: $slider.data('adapt'),
arrows: true,
dots: true,  
pauseOnHover: false
pauseOnFocus: false,

 

 

For me this worked.

 

Edit: The slideshow is now running, but still pauses on Hover. So it's not working 100%.

Sky8484
Tourist
5 0 1

Can someone please help me. My site went live today and I really want to have this error fixed before I announce it to the world.  Please help me fix this issue.

RoyalFireCo
New Member
2 0 0

I searched my code for several of the lines you suggested, and found none of that. My theme is not java, somehow, so I have theme.liquid , not theme.js.liquid (this is at the top of the code... <html class="no-js" lang="{{ shop.locale }}">) Why is this, and what can I do to fix the slider pause problem?

supportRose
New Member
2 0 0

Hallelujah! Love your solution. Thank you so much! So simple and works so perfectly.