Can't connect to eBay

Solved
sologlory
Tourist
7 0 1

I suddenly can't connect from my Shopify home to my eBay account, though I had no trouble yesterday or the day before. What am I missing?

Accepted Solution (1)

Accepted Solutions
waltlovescomics
Excursionist
11 1 5

This is an accepted solution.

Hey there,

 

had the same problem (looping) on Safari. This is how I fixed it:

Go to Preferences/Privacy and uncheck "Prevent cross-site tracking" (if active). 

 

Worked for me!

 

Best
Walt

View solution in original post

Replies 21 (21)
Katy
Shopify Staff
Shopify Staff
779 43 175

Hi, @sologlory !

 

Katy here from Shopify. I hope you are well and thanks for reaching out.

 

That is a little strange. We have not had any other reports of this. Would you be able to share a screenshot of what you can see? For example, any error messages or flags?

 

Below are the requirements for the eBay sales channel. Could you ensure that you have not adjusted any of the following:

 

As this is a third party sales channel, usually the best point of contact would be the channel developer directly. If all of the above information is in order, and you are not seeing any errors, I do suggest to reach out to them here or here (depending on the exact service you are using).

 

I do hope that this helps, and that you have things up and running again soon.

 

Cheers,

Katy

 

 

Please note: This account is no longer regularly monitored.
 - If you need assistance please do start a new topic (referencing an older topic/post if you find this helpful).
 - Thank you for your understanding. We hope you enjoy exploring the Community.
 - To learn more visit the Shopify Help Center or the Shopify Blog.

sologlory
Tourist
7 0 1

Invalid Request or Access Unauthorized

sologlory
Tourist
7 0 1

Also, I discovered by deleting then re-adding eBay works, and retains previously entered data. This only works for a single session.

sologlory
Tourist
7 0 1

The culprit seems to be the Firefox / Linux combination. Other browsers on Linux render my eBay account well.

 

Katy
Shopify Staff
Shopify Staff
779 43 175

Ah that is interesting, @sologlory.  Great digging there, and thanks for sharing. 

 

I suggest to touch base with the app developer regarding this, if you have not done so as of yet. Though I hope that working with a different browser helps in the mean time.


Cheers,
Katy

Please note: This account is no longer regularly monitored.
 - If you need assistance please do start a new topic (referencing an older topic/post if you find this helpful).
 - Thank you for your understanding. We hope you enjoy exploring the Community.
 - To learn more visit the Shopify Help Center or the Shopify Blog.

MyCave
New Member
3 0 0

I have just had this same issue.. 

i have deleted and tried to reconnect and it gives me the same error 

Invalid Request or Access Unauthorized
MyCave
New Member
3 0 0

I have sorted this.. It was a cookie issue. 

 

tideline3d
New Member
2 0 2

For future google searchers like me, this ended up working for me in a different browser.  I didn't dig into why that worked, as it only mattered for initial setup, but switching from Safari > Chrome got around this for me.  

I can't use the eBay module in Safari after registering either, it just gets stuck in a redirect loop. 

bisyclothing
New Member
1 0 1

I have been having this issue for months, I spoke to Shopify and they just told me to update safari but all my programs are up to date, I wish someone would give it some importance, its a major issue that needs to be addressed.

catestrange
Tourist
4 0 3

This is my errerror message.JPGor message of 5 days now : (

TCResale
New Member
2 0 1

We are having exact same issue. Has anyone helped you with this? Very annoying. We have never been able to have our items go up on ebay .

 

OldNavy72
Tourist
6 0 4

Ditto here! This has been going on for quite a while. UI am on Windows 10 (updated Pro version) and I use Chrome (updated) as my browser. I will try later on using my iPad Air 2 in several configurations and browsers. Everything I use is either connected to my router via Ethernet or WiFi. I have no trouble using Chrome and logging in, the anomaly occurs when I am in  Shopify and try to add eBay as a sales channel.  At first, it worked, then something disconnected my account, and when I attempted to connect again I got this very curt error message, "<Access Denied.> I would wait a few days, performing cache clearing, house cleaning, restarting, having W10 see if she could find anything, and try again, same results, ad nauseum. So, it seems that there is either some erroneous code being sent by Shopify triggering these responses, or something on eBay side that when it receives the connect request from Shopify that triggers these responses. Any way you look at it, my money is the onus is on Shopify. Sorry.

Doug

thrifstagals
New Member
1 0 0

We are receiving the exact same error message. Any updates on a solution for this? 

MyCave
New Member
3 0 0

Hi 

I fixed this. 

In my case it was to do with cookies not being allowed access - i just gave them permission and it worked ok after that. 

 

I only though of this as i had done some cleaning up the day before.. 

 

hope that helps. 

Andrew

 

 

OldNavy72
Tourist
6 0 4
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><meta name="Generator" content="Microsoft Word 15 (filtered medium)" /><!--<br>/* Font Definitions */<br>@font-face<br> {font-family:"Cambria Math";<br> panose-1:2 4 5 3 5 4 6 3 2 4;}<br>@font-face<br> {font-family:Calibri;<br> panose-1:2 15 5 2 2 2 4 3 2 4;}<br>/* Style Definitions */<br>p.MsoNormal, li.MsoNormal, div.MsoNormal<br> {margin:0in;<br> font-size:11.0pt;<br> font-family:"Calibri",sans-serif;}<br>a:link, span.MsoHyperlink<br> {mso-style-priority:99;<br> color:blue;<br> text-decoration:underline;}<br>.MsoChpDefault<br> {mso-style-type:export-only;}<br>@page WordSection1<br> {size:8.5in 11.0in;<br> margin:1.0in 1.0in 1.0in 1.0in;}<br>div.WordSection1<br> {page:WordSection1;}<br><br>
Kenneth17
New Member
1 0 0

16001226217429028051309949730887.jpg

 I can't get pass this 

evscotters
New Member
1 0 0

It's still going ill send you a screenshot someone fixes it as I need it for my eBay store asap. Must need an update or something

 

I'm From the UK,ebay.png

it is not a geographical error it is just a system bug.

 

Katy
Shopify Staff
Shopify Staff
779 43 175

Hi All, 

I hope you are keeping well. I would like to apologize here for the lack of response on this thread. This account is no longer regularly monitored and I have updated my signature to reflect this. 

Having a look into this, it does appear to be browser related. However, I notice some of you have mentioned clearing your cache and testing via a different browser without success. In this case, the best method to receive support for this Application/raise this issue, is via the App developers directly. You can find them here via our App store (where we track replies to make sure replies back to you are timely) or you can choose to reach out to them directly via email or via their contact form.

I am going to close off this thread, but if you feel that you need further support from our Community, you are welcome to start a new discussion, or to reach out to our team directly; you can do so via our Help Center here, or via Facebook Messenger or Twitter.   

Thank you for taking the time to share your feedback and wishing you a pleasant and safe New Year. 

Katy

Please note: This account is no longer regularly monitored.
 - If you need assistance please do start a new topic (referencing an older topic/post if you find this helpful).
 - Thank you for your understanding. We hope you enjoy exploring the Community.
 - To learn more visit the Shopify Help Center or the Shopify Blog.

waltlovescomics
Excursionist
11 1 5

This is an accepted solution.

Hey there,

 

had the same problem (looping) on Safari. This is how I fixed it:

Go to Preferences/Privacy and uncheck "Prevent cross-site tracking" (if active). 

 

Worked for me!

 

Best
Walt