FROM CACHE - en_header
Return management just got easier! We’ve launched Customer Self-Serve Returns to all Shopify merchants. Click here to learn more!

Cart disappears on mobile browsing (some devices, some browsers)

Arteanaceo
New Member
2 0 0

Hi Community,

We've just discovered a major bug on our site www.arteanafashion.com (theme: Showcase by Clean Canvas), resulting in carts disappearing through at least the following two paths:

a) add to cart -> view cart -> checkout -> product disappears (iPhone 6s, safari + perhaps other types)
b) add to cart -> view cart -> change currency -> product disappears (unknown mobile device, safari + perhaps other types)

On desktop and other mobile devices everything seems to be working fine so it's not always possible for me to replicate the issues.

However, some days we have 80-100 ATC with 0-1 purchases so I'm concerned that there are many more paths/devices where the carts end up disappearing.

Link to Hotjar to see issue b): https://insights.hotjar.com/r?site=2259963&recording=5179427607&token=b26682ef61fc7164a3bf3d8e8ba7ef... (skip to 6.30 mins)

With no technical background it is extremely difficult for me to understand how to troubleshoot this and if it's an issue with Shopify, Showcase theme or any apps installed.

I'd highly appreciate if anyone could guide us in the right direction.

Thank you so much!

Mikkel

Replies 14 (14)
aliceshops
Tourist
8 0 2

hello there, wondering if you have found a solution? I think I have the same problem on my store. carts are emptying on mobile devices. seems to be just I phones 

thanks for your help in advance 

Alice

David28
Explorer
79 0 13

I'm having the same issue. Losing lots of customers. I've made no changes to my site but it's happened suddenly. Shopify support just say it all works fine when they try it. But my customers say otherwise. I've even tried publishing an old version of my website from months ago but it hasn't made any difference so I know it's not due to any changes I've made.

aliceshops
Tourist
8 0 2
Hello,

Oh no it’s rubbish. Shopify have told me to contact the theme people but they don’t work weekends. When I spoke to Shopify yesterday they could see it was happening on their mobile devices. (It is only broken for me it seems on IPhones and works on iPhones if used on private browsing mode) Can I ask what the theme you have? Mine is prestige

Thanks for replying. Good to know it’s not just my website. When did it start for you? I think mine started Saturday am (UK time)

David28
Explorer
79 0 13

My theme is Minimal v9.0. problem happens in Firefox on computer an mobile phone. works fine on Chrome on computer but when I try Chrome on iPad the problem happens there!! bizarre. doesn't make any sense. I'm not certain when i started but I would also agree it was early Saturday and possibly Friday judging by the lack of orders.

aliceshops
Tourist
8 0 2
Hmmm okay. I might contact Shopify again now. It’s so painful knowing you’re losing so many orders. Fingers crossed the theme people get back to me with a solution tomorrow. Will let you know if I find anything!
David28
Explorer
79 0 13

Yes please. I'm glad to hear (in a way) that someone else has the same problem as I've spent hours trying to identify the issue and found nothing wrong. i don't think it's theme related though as we have completely different themes. I'm also surprised that nobody else is having the issue if it's a Shopify-caused fault. the fact that even my months-old version of my website that i've re-published is also having the same issue definitely suggests it's being caused by something wrong with Shopify's checkout code (as we have no access to that or control over it).

aliceshops
Tourist
8 0 2
Yes makes sense. I did the same thing publishing an old version of my theme and had the same problem with checkout there. Speaking to them now. Perhaps now that the problem has been happening for a bit longer they might be taking it seriously / have other people with same problem contacting them
David28
Explorer
79 0 13

Did you get anywhere with Shopify? I was on for ages with live chat but they don't understand the problem. It's been escalated apparently.

aliceshops
Tourist
8 0 2
Hello, yes! The theme people have just fixed it for me. It was caused by mailchimp. So mailchimp is now deleted and all is good!
David28
Explorer
79 0 13

I envy you! I'm getting nowhere. I don't have mailchimp so I'm even more confused as to what the problem is now.

Arteanaceo
New Member
2 0 0

Hey guys,

Sorry about the delay in getting back to you.

My (initial) cart bug was caused by the native currency selector (+Shopify Multicurrency + Shopify currency app). After uninstalling all of this and installing a third-party currency app, most of the bugs have disappeared.

However, I've just identified another cart bug when you a) change currency, b) remove item from the cart, c) add new items to cart  - you are then unable to proceed to proceed to checkout. The bug "stays" with the user until they switch the currency to default (EURO) and try again so it indicates that Shopify has some bugs to fix related to they Multicurrency checkout feature.

My recommendation would be to hire a freelance Shopify developer to investigate the issue as I would not have identified/solved the problems myself.
 
Hope it helps @David28 - Happy to hear you've fixed your bug @aliceshops. Would be great to get some input from the Shopify team as well.

Best,
Mikkel

aliceshops
Tourist
8 0 2

Oh no. Bacially the theme guy that helped me tested disabling each of my aps one by one. and so thats how he focused in on mailchimp. so maybe disbale each of your aps one at a time as he did? he said that virtually all issues like this are ap related so I hope it works if you didnt try already 

MysticalQuartz
Excursionist
12 1 2

Have the same Issue over here. Not working on Firefox or IOS devices. Such a pain! My CR is falling down cause oh this!!!!! Please provide us a solution to this matter fast. This is a big disaster.

David28
Explorer
79 0 13

Issue still persists for me today. More lost orders. Tried disabling each app but it still happens. Very frustrating!