Dawn 2.0 - How to disable image zoom on hover

Solved
jbk1
Tourist
4 1 1

There's no option for this in theme editor so I'm trying to find and adjust the css that's triggers this zoom on  hover effect, but I cannot find it. (Commenting out `.product__modal-opener--image .product__media-toggle:hover {cursor: zoom-in;}` does not stop it, so this can't be the effect). Thanks

Accepted Solution (1)

Accepted Solutions
jbk1
Tourist
4 1 1

This is an accepted solution.

The effect in question is the `transform: scale(1.03);` effect which in Dawn 2.0 resides in `assets/component_card.css` in three places:

 1) .card:hover .media.media--hover-effect > img:first-child:only-child,
.card-wrapper:hover .media.media--hover-effect > img:first-child:only-child {
transform: scale(1.03);
}

 

2) .card-wrapper:hover .media.media--hover-effect > img + img {
opacity: 1;
transition: transform var(--duration-long) ease;
transform: scale(1.03);
}

 

3) .card-wrapper:hover .card--search img {
transform: scale(1.05);
}

View solution in original post

Replies 3 (3)
Shay
Shopify Staff
524 86 101

Hi @jbk1 

 

I checked in with my theme support team about this question to see if this is a customization request they would support. They said that isn't a feature our in house theme support would look at removing and that the reason it was included in the Dawn theme was to increase accessibility. The slight zoom makes it easier for customers with low vision or mobility to know they have their cursor over the right product or area of the store. 

 

They did recommend considering an Out of the Sandbox theme, which has tutorials on how to remove the image zoom with mouse hover: OOTS - Disable Hover to Zoom on Product Page images.

Shay | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

jbk1
Tourist
4 1 1

Hi @Shay , thanks for asking the at your end. I understand the accessibility pov, though this zoom feature negatively impacts the visual design. The edges of images that I'm using are important to render and this zoom effect zooms the image within a fixed frame which itself does not zoom, therefore un-zoomed image looks fine with edges rendered intact, hover and image auto zooms and chops the edges of the image off because of the fixed frame within which image is zoomed. So really my question is where can I find the selector creating this effect so that I can override it, and or the fixed frame within which the image is rendered so that I can zoom that also on hover? Thanks

jbk1
Tourist
4 1 1

This is an accepted solution.

The effect in question is the `transform: scale(1.03);` effect which in Dawn 2.0 resides in `assets/component_card.css` in three places:

 1) .card:hover .media.media--hover-effect > img:first-child:only-child,
.card-wrapper:hover .media.media--hover-effect > img:first-child:only-child {
transform: scale(1.03);
}

 

2) .card-wrapper:hover .media.media--hover-effect > img + img {
opacity: 1;
transition: transform var(--duration-long) ease;
transform: scale(1.03);
}

 

3) .card-wrapper:hover .card--search img {
transform: scale(1.05);
}

View solution in original post