Error: There's no page at this address

Trazi
Shopify Partner
3 0 1

After reInstall app, I see this message
There's no page at this address
Check the URL and try again, or use the search bar to find what you need

All ok locally, with ngrok tunnel.

Steps to reproduce the problem

  1. Create Node App
  2. Do simple changes
  3. Deploy to hosting (I used Digitalocean)
  4. Make changes on App Settings page(change URL and redirect URL to hosting urls)
  5. Install app to Development store
  6. Delete the app from the Development store
  7. Repeat Install app to Development store
  8. Get this error.


The issue on Github: https://github.com/Shopify/shopify-app-node/issues/602

Replies 17 (17)

vishalsharma12
Tourist
4 0 1

I have got the same error after reinstalling the Private App.

Trazi
Shopify Partner
3 0 1
Vukona
Tourist
7 0 1

Sadly, this never worked.

Mnisi V
mschristian
Shopify Partner
7 0 4

Shopify support have been investigating this for months but have not found an answer yet, we get this issue with all apps at the moment

mschristian
Shopify Partner
7 0 4

Found a solution to this, it sounds like it is a issue/feature with Shopify App Bridge and it is related to

 

"Because the shopOrigin cookie is set during authentication, you'll need to re-authenticate your app in your store's admin" if you search that on the internet you get a bunch of results from different languages and systems all related to Shopify App Bridge

 

The solution is to access your app manually and having the shop-name as a single GET argument, like this

https://my-app-domain.com/?shop=my-test.myshopify.com

and this will make the app work again, at least it worked for me

Romainpi
Visitor
1 0 7

Hey, it's been happening to me as I was trying install/uninstall and I have managed to understand why it may happen to some people:

 

If you uninstall the app while your code is not running, your app will not receive the `app/uninstalled` webhook and will not remove the shop tokens from the SESSION_STORAGE which is by default stored in a `database.sqlite` file. Then your app will detect your shop as already installed/registered (so no need to send you to the install screen) and will try to initialise the session with Shopify but Shopify will kill it because it's using old tokens.

 

The simple solution is to get in the `database.sqlite` and remove your shop's corresponding session, or just delete `database.sqlite` and restart your app.

mschristian
Shopify Partner
7 0 4

This did not work for me, I cleared the session database locally and still got the same error, the only way to resolve it was to manually visit to Oauth URL of my app

adamgen
Shopify Partner
10 0 5

Thanks for leaving this comment. Visiting the Oauth URL worked for me after about 2 hours spent on it... In case it helps someone else, the auth URL is 

 

```

```

 

Replacing the obvious parts of the URL with yours.

Fractional VP R&D for E-commerce
darlegz
Shopify Partner
1 0 1

This worked for me! Thanks so much!

1080
Shopify Partner
282 8 39

@darlegz   can you please share the complete solution.

Deepjpatel
Shopify Partner
1 0 0

@darlegz please send me solution 

Nicholas_Babu
Shopify Partner
6 0 0

I was struggling to re-install my app (and register scripttags with

new ScriptTag({session}))

 Your solution solved my issue.

Mybelle
Visitor
1 0 0

Hey I'm having a problem installing tiktok on my store due to this issue. Could you help me?

Nicholas_Babu
Shopify Partner
6 0 0

Try @Romainpi solution, deleting the `database.sqlite` and restart your app.

Brandon-Flexi
Shopify Partner
9 0 5

It worked like a charm! I deleted the database.sqlite file then restarted my app! THANKS 🌟

oehc123
Shopify Partner
5 0 1

I realized that I was getting that error because the name of the app was the same as the name of an app that i had installed previously.

I solved this by simply changing the name of the app from. `micro-app` to `micro-app2`.

once `micro-app2` was installed, then I tried to install `micro-app` again, and it work fine

SK_TG
Shopify Partner
17 0 5

For anyone with the same error, go to the live database connected to your code and remove the app credentials. 
Then try to re-install. The matter would be resolved.