Solved

Exporting problem/ special characters

Mayera
Visitor
3 0 0

Hi guys,

I am desperate for some help. Everytime I export a report of products sold into CVS from the site, it comes out with special characters in them replacing some of the vowels.

Like this: "gyerek okosóra kiegészítÅ‘" instead of this  "Gyerek okosóra kiegészítők". These are hungarian characters. 

I have tried switching to hungarian excel, nothing changed. I made sure it is decoded as UNICODE (UTF-8) and tried to import from CSV or txt format. Again nothing changed. The problem is that the CSV dowloaded from Shopify already contains these characters and I can't think of anything else to do to change them back.

Please let me know if you know any solution to this, it would mean a lot.

Thanks.

 

 

 

Accepted Solution (1)

hajaco
Visitor
1 1 4

This is an accepted solution.

Hey there, I hope this solution doesn't come too late for you.

I had the same problem with greek characters, so I fiddled around till I found a solution:

It appears that Excel is picky about importing .csv files encoded in UTF-8, because it seems to need the encoding to be of type UTF-8 BOM.

So what I did was, I opened the .csv file in Notepad++, changed the encoding from UTF-8 to UTF-8 BOM, and saved the file, and then the import went fine.

 

I hope this will help you, and anyone else who has problems with special characters when importing a .csv to Excel.

View solution in original post

Replies 3 (3)

productsync
Shopify Partner
740 38 159

Hi

Excel doesn't support opening CSV files with UTF-8 characters so try doing the following:

  1. Open Excel
  2. Import the data using Data > Import External Data > Import Data (or From Text option)
  3. Select the file type of “csv” and browse to file
  4. In the import wizard change the File Origin to “65001 Unicode (UTF 8)” (or choose correct language character identifier)
  5. Change the delimiter to comma
  6. Select where to import to and Finish

Hopefully that helps.

Regards

Tom

hajaco
Visitor
1 1 4

This is an accepted solution.

Hey there, I hope this solution doesn't come too late for you.

I had the same problem with greek characters, so I fiddled around till I found a solution:

It appears that Excel is picky about importing .csv files encoded in UTF-8, because it seems to need the encoding to be of type UTF-8 BOM.

So what I did was, I opened the .csv file in Notepad++, changed the encoding from UTF-8 to UTF-8 BOM, and saved the file, and then the import went fine.

 

I hope this will help you, and anyone else who has problems with special characters when importing a .csv to Excel.

Cstola
Visitor
1 0 0

Hi there,

 

Just wanted to say thank you!

Your post came through the shopify helpcenter, even after a few years.

Your solution worked like a charm!

I was having a bit of trouble with exporting Hebrew text, but your fix sorted it out perfectly.

 

For anyone else who might be wondering about changing the encoding, Just hit 'save as' and choose encoding UTF-8 BOM.

 

Thanks again for your help, it's greatly appreciated!