How can I disable Google reCAPTCHA?

takakotucker
Visitor
2 0 0

Trying to opt opt for Google reCAPTCHA but it seems to be impossible. 

https://tokoboma.myshopify.com/

 

It does get redirected to /challenge.

Any way of forcing redirect to customer_posted=true ? 

 

 

 

Replies 6 (6)

Don
Shopify Staff
2777 199 390

Hi there @takakotucker!

 

Thanks for sharing your query and your store link with us here in the Shopify Community.

 

It looks like you're still working your way towards launching your store, can you tell me a bit more about your business?

 

Could you just specify for me, where exactly in your store is the captcha you're referring to here?

 

There are a couple of instances of captchas that are used in Shopify stores, so if you can specify which one it is and where it's being used that will help us to understand what your options are for removing or disabling it here.

 

If this is part of a process used in collecting customer information, you can learn more about how to collect and use customer contact info here on our help site.

 

Let me know as much as you can about your business and your requirements here so we can work on this together!

Don | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

takakotucker
Visitor
2 0 0

Hi Don,

Thanks for getting in touch and sorry for my late reply. 

 

So https://homerunpet.jp/ is our URL, waiting to be launched however we are still facing a suspected reCAPTCHA issue. 

At the moment, I had to force redirect (bypassing reCAPTCHA screen) to https://homerunpet.jp/?contact%5Btags%5D=customer_posted&form_type=customer#contact_form once newsletter form is submitted. We don't want any CAPTCHA and just need to collect email addresses to avoid turning away some potential buyers. 

 

The redirect solution is not ideal however works for us at the moment. However some email input is not being recorded which I suspect due to the force redirect? 

 

Anyway the outcome we want are: 

 

  1. Turn off Google reCAPTCHA completely for newsletter sign in (there are two forms on the page
  2. All email submission should be saved successfully in KLAVIYO (third party app) 

 

Thanks for your help

 

Takako

Don
Shopify Staff
2777 199 390

Hi again @takakotucker!

 

Thanks for getting back to me here and for sharing that link to your store.

 

Apologies, as I'm having a hard time understanding from the site itself; can you confirm if the captcha in question here is prompted when customers are creating accounts or when signing up for your newsletter?

 

This info will help us to determine how you might be able to get support for this, based on where exactly the captcha is.

 

Are you using a third-party service, such as Klaviyo, to collect emails or newsletter signups, and is this where you're looking to disable the captcha or is there somewhere else in your store you need to be able to do this?

 

The more information you can give us here the better we will be able to understand and help out.

Don | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

Bricklayer
Tourist
7 0 2

I'm having this same exact issue. Were you able to figure out how to solve it? I would appreciate the help as I see the Shopify staff response was basically useless. 

Erin
Shopify Staff
986 131 157

Hi, @Bricklayer. You can disable Google reCAPTCHA by going to Online Store > Preferences in your Shopify admin and scrolling down to the 'Spam Protection' section. I wouldn't be able to comment on how this interacts with any third party apps you're using, but if you disable the "Enable Google reCAPTCHA on contact and comment forms" setting in your Shopify admin, this will prevent reCAPTCHA on contact and comment forms.

Erin | Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

Bricklayer
Tourist
7 0 2

I actually figured it out. So the settings for reCAPTCHA were off yet the box was showing up still on my site. So I enabled reCAPTCHA saved it, then disabled and saved it and it worked. Not sure if it's a bug in Shopify but the important thing is that the desired outcome was reached.