How to fix the 'bundle install' error in Shopify theme development?

kimville44
Shopify Partner
2 0 1

I have some trouble here. I am trying to connect my Shopify store using Shopify theme dev --store however the output says
-------------------
Error coming from `bundle install`

Command failed with exit code 5: bundle install
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

An error occurred while installing ffi (1.15.5), and Bundler cannot continue.

Fetching gem metadata from https://rubygems.org/..........
Resolving dependencies...
Installing ffi 1.15.5 with native extensions
-------------------
Has anyone encountered the same error before? May I know how you resolved it?

 

Reply 1 (1)

wayforward
Shopify Partner
13 0 1

I am getting the same error but in app. How did you resolve it?