<meta name="viewport">tag not working

Claclac
Tourist
11 0 1

Hi,guys!

Please help me as <meta name="viewport">` tag is not working.

As you can see in the attached image, the meta name="viewport" tag has been inserted, but PageSpeed Insights still throws an error no matter how many times I try.


Here is my website.

https://claclacstore.com/

It would be helpful if someone could tell me why the <meta name="viewport">` tag doesn't work and how to fix.
thank you.
PageSpeedInsight.jpgWebpage.jpg
Code.jpg

Replies 4 (4)

NomtechSolution
Astronaut
1245 113 146

It looks like you're facing an issue with the <meta name="viewport"> tag not working as expected. The viewport meta tag is crucial for ensuring proper responsiveness and display on different devices. Here are a few steps you can take to troubleshoot and resolve the issue:

  1. Verify the placement: Make sure the <meta name="viewport"> tag is placed within the <head> section of your HTML code. It should be placed before any other CSS or JavaScript files.

  2. Check for conflicting code: Ensure that there are no conflicting CSS or JavaScript codes that might be overriding or interfering with the viewport settings. Look for any other viewport-related tags or CSS properties that might be conflicting.

  3. Check the syntax: Double-check the syntax of the viewport tag to ensure it is correct. It should resemble the following:

 

 

<meta name="viewport" content="width=device-width, initial-scale=1.0">

 

 

  1. Pay attention to the placement of quotes, commas, and the values of the content attribute.

  2. Clear cache: If you have previously tested the <meta name="viewport"> tag and it didn't seem to work, try clearing your browser cache. Sometimes, cached versions of your website might not reflect the recent changes you made.

Claclac
Tourist
11 0 1

Thank you for your suggestion!
I tried all you suggested but it didn't work...

Do you still have any idea to solve this problem?

thewatchtrend
Visitor
2 0 0

Hi, I am also facing this issue. I added the updated code <meta name="viewport" content="initial-scale=1, maximum-scale=1"> to the head section of the theme.liquid file. But it still says 'does not have a <meta name=....>.

 

thewatchtrend_0-1684770192590.png

Please could someone adivse why this is not being picked up?

 

marklloydbinar
Shopify Partner
5 0 0

Put the code after the <head>

 

Make sure after the <head> line..