Need help with DNS settings for third party email set up

shawnhebert
Visitor
3 0 0

I recently switched web hosts from Weebly/Square to Shopify.  I'm trying to get my Zoho email to work, but I cannot receive emails, only send.

 

I followed the steps to change the DNS settings (adding the CNAME zb14832931 zmverify.zoho.com, The MX records, and the TXT @ v=spf1 include:zohomail.com ~all) , but it's still not working.

 

By following the instructions from Zoho, the MX records mx.zoho.com, mx2.zoho.com, and mx3.zoho.com are added to the DNS settings.  The instruction article said that the automatic changes are generic, and that I would have to use MX records specific to my region.  I changed the MX records manually to what is seen in the attached photo, which the Zoho instructions said to use.  Neither set of MX records is working.  In both scenarios, I can only send emails and not receive emails.

 

I don't know what the CNAME records mailerak1 and ak1._domainkey, ak12._domainkey, and ak13._domainkey are, and am wondering if those need to be deleted.

 

Any help would be greatly appreciated.

Shawn
1.jpg

Replies 3 (3)

shawnhebert
Visitor
3 0 0

I don't know if this will be helpful at all to anyone that can help me with this, but I just got an email from amazon come through, so I thought the email was now working fine.  I sent a test email from my personal email address, and it didn't go through.

SAN_MSWEB
Shopify Expert
1094 130 136

Hello,

 

I am San from MS Web Designer.

 

If you are experiencing this problem, you will need to add a DMARC record. You can find this record in the settings under notifications. Click on "authenticate your domain" and then add all the records shown in the popup to your domain's DNS settings. Additionally, you will need to contact your email service provider to request the necessary email DNS records to connect your email with your domain. Once you have added these records to your domain's DNS settings, you will be able to start receiving emails from Shopify.

SAN_MSWEB_0-1715422451294.png

 

Hope this helps.

 

Do let me know in case of any concerns.

 

Regards,

San

 

 

 

 

If it’s helpful to you, please mark it as a solution.  


Need Help with Shopify Design, Migration, Speed, or Custom tasks?  
email: hi@mswebdesigner.com
Try Our Conversion Booster app to get more sales | Connect Our Founder Linkedin

shawnhebert
Visitor
3 0 0

Hi San

 

I already did the 'authentic your domain' under notifications when I set up my domain.  This was probably on Apr 30th.  This morning I had a few emails come through, so I did another test email from my personal email, and it went through as well.  I tried a test email from the contact page of my website, and that still isn't going through.

 

I deleted the DMARC record v=DMARC1; p=none, and added the DMARC record from zoho: v=DMARC1; p=none; rua=mailto:shawn@lailokensawen.com; ruf=mailto:shawn@lailokensawen.com; sp=none; adkim=r; aspf=r

 

I assumed I needed to delete the original DMARC record.

 

After I did that, I sent another test email from my personal email and it sent through, but still nothing when I send from my contact page.

 

In my zoho mail admin console, it says my domains MX records are pointed to zoho, my SPF records have been pointed successfully, and my DMARC records is pointed for this domain: v=DMARC1; p=none; rua=mailto:shawn@lailokensawen.com; ruf=mailto:shawn@lailokensawen.com; sp=none; adkim=r; aspf=r

 

DKIM isn't set up, does it need to be?

 

Thanks

Shawn