Should I be using both my .com and .co.uk domains?

Mikey77
Visitor
2 0 0

Hey everyone! I am stuck on what to do and I was hoping that someone could point me in the right direction.

So I have built my website under my .com domain and submitted the sitemap to the Google Search Console. My primary market on Shopify is set to the United Kingdom, however, I have also added the United States as a market. 

My question is if I should now point the UK market to the .co.uk domain and the United States to the .com domain. If this happens to be the correct route to go then would I need to make any changes to my url's as currently they all point to the .com domain? Or am I better just leaving both markets under the .com?

I do also have the .shop and .store domains, should I add these in the domain section of Shopify, or does this not matter. 

Any help is appreciated.

Many thanks


Replies 3 (3)

StephensWorld
Shopify Expert
1138 124 289

If you are just selling to 2 markets:

 

I'd point the .co.uk domain to your UK market (make it the primary domain), and then point the .com to your United States market.

The other domains (.shop and .store) can be added and forwarded to your .co.uk domain.

 

If you're selling to more than the above markets, then I'd just stick with your .com domain as the primary, and then add all of the rest of the domains to your domains section, and have them forward to the .com domain. 

 

It's really just personal preference / branding to consider. There's no 'wrong way' to do this -- it's however you want it to work. 

★ Did my post help? If yes, then please like and accept solution. ★

Hire me for your Shopify project @ stephens.world | support@stephensworld.ca

Mikey77
Visitor
2 0 0

Thats great! Many thanks for your reply.

Eventually, I would like to add more markets so I think I will stick to the .com domain then. 
My concern was that by using the .com I would rule out any organic traffic from the UK. However, I am assuming that this is not the case.

Cheers

anillrao
Tourist
3 0 0

Totally agree with @StephensWorld 

 

Also, make sure your "hreflang" tags are properly assigned.