Why am I getting 'command theme:serve not found' error in Shopify theme setup?

Why am I getting 'command theme:serve not found' error in Shopify theme setup?

Not applicable



I'm just getting started with Shopify. I successfully downloaded the default Dawn theme into my repo for my mock store.


When I run the 'shopify theme serve' command, my Terminal gives me this error:


command theme:serve not found

My file directory structure matches the default and I even got rid of the README.md file that I initially had, just to see if it would make it a difference. Still the same error.


Using a Mac M1 on macOS 13 Ventura, if that makes any difference.


Anyone else run into this error?

Replies 3 (3)

Shopify Partner
6405 584 1358

Try > shopify theme dev


They've messed up the theme design/development workflow again

https://github.com/Shopify/shopify-cli 2.0-2.3 for themes

https://github.com/Shopify/cli for apps

See https://github.com/Shopify/shopify-cli#note-on-shopify-cli-20-versus-shopify-cli-30 


If you recently started and have a version 3 or greater of the shopify-cli they changed the commands names for some dumb reason so it's more inscrutable to use and outdates a TON of documentation.


If you read "shopify theme serve" in dev docs there is a feedback button on almost every section, use it.

If it's on some other shopify site report it to support that it's outdated.

Or create a ticket in the shopify-cli github repo itself https://github.com/Shopify/shopify-cli or the newer https://github.com/Shopify/cli  /shrug /ugh


Save time & money ,Ask Questions The Smart Way

Confused? Busy? Get the solution you need paull.newton+shopifyforum@gmail.com

Problem Solved? ✔Accept and Like solutions to help future merchants

Answers powered by coffee Buy Paul a Coffee for more answers or donate to eff.org

Not applicable

Thank you for your reply!

Shopify Partner
14 0 8

Thank you Paul!