Why is my CSV product upload constantly failing due to image validation?

1 0 0

Have attempted to upload a CSV file with 200~ products five times today. Same style I do weekly. Each one has resulted in an error "Validation Failed: Image" - "failed to download - timeout reached. Make sure file can be downloaded successfully". The links in the email citing failed work fine when I click them & each upload I have received a different amount of errors and for different products (some work on one, and then not on the next attempted upload).  I have tried from different networks with, and used different links for my most recent upload, with  no success. Help!

Replies 4 (4)

Shopify Expert
235 28 44



are the image urls available at the time you do the import? Normally that error message means that for any reason Shopify is unable to download your pictures, most of the times, because the images are not available on the provided URL, which seems not to be your case.


If you want we could have a deeper look for you. Just write us at info@webmefy.com and we would love to help you.

We help you achieve your Goals! Visit us on: Webmefy.com
5 1 1


I have the same problem. My product list has 480K+ items. 


The file provided by supplier has 3 different URLs

1- pointing at the product page on their main website. Image there is in .webp format

2-pointing at the image for the product image in .webp format

3- pointing at the image for the product with .jpeg format 

 they all use https. I tried http as it was suggested by someone as a possible solution but did not work. 

I tried to copy the image address from the product page and used it for image source but did not work either. 


I would appreciate any suggestions that could solve this issue. As i am stuck unable to proceed unless is enter the product manually, but with that large product list it is a nightmare. 

1 0 0

I uploaded all products now with a random image and then started uploading images product wise manually. at least saved up on time of adding all product details manually. Thank you so much for all the  help. 

1 0 0

Did you manage to find a fix for this? Ive got the same issue