FROM CACHE - de_header

Complementary Product isn't shown on live site

Gelöst

Complementary Product isn't shown on live site

moritzgut
Shopify Partner
5 1 0

I am using the "Dawn" theme.

I have added a complementary product to some other products by using the Search & Discovery Plugin.

Then I've added the Complementary Product Block to the template these products use. I can see the complementary product in the editor and I can use the block to add it to the cart. This is all working fine.

 

What I am expecting:

When I save the product and switch to the live site (it's still behind password protection) the complementary product should be shown like in the editor.

 

What I am experencing:

When I save the product and switch to the live site (it's still behind password protection) the complementary product isn't showing up. It's like the element isn't there.
Only sometimes – i couldn't figure out any kind of pattern for this by now – the block is randomly shown for one product. But when I reload the page it's gone again.

 

Does anyone know how to solve this or where to start looking into this?

1 AKZEPTIERTE LÖSUNG

moritzgut
Shopify Partner
5 1 0

Erfolg.

This is a caching issue in dev mode. Just delete all site data and it works again.
I also noticed that if the product is in the cart it won't show up on other products – even if it has multiple variants that can be purchased.

Lösung in ursprünglichem Beitrag anzeigen

2 ANTWORTEN 2

Niklas_g
Shopify Partner
34 8 22

Hey Moritz,

can you check if the recommended products are in stock and not sold out? Otherwise you could try to increase the inventory.

moritzgut
Shopify Partner
5 1 0

Erfolg.

This is a caching issue in dev mode. Just delete all site data and it works again.
I also noticed that if the product is in the cart it won't show up on other products – even if it has multiple variants that can be purchased.