FROM CACHE - de_header
Gelöst

Problem mit den cookie Richtlinien von Shopify

Kummer
Besucher
1 0 2

hallo Mein name ist Eric, 

ich habe ein Riesen Problem mit meinen Account. Shopify will ständig das ich Drittanbieter-Cookies in meinem Browser Aktiviere, habe ich getan. Soweit so gut Trotzdem taucht immer wieder dieses Fenster auf: 

Drittanbieter-Cookies zulassen 

Bitte aktiviere cookies oder verwende einen anderen Browser für eine sichere und bessere Browser-Erfahrung. 

Erfahre hier wie du Drittanbieter-Cookies Aktivierst.

 

vielleicht kann mir ja jemand von euch helfen, bin schon seit stunden auf der suche nach einer Lösung.

1 AKZEPTIERTE LÖSUNG
rockstar3000
Entdecker
26 2 11

Erfolg.

Ja, aber egal was ich da eingestellt hatte, mein GDPR Cookie Banner von Beeclever wurde immer angezeigt, bei jedem page reload.

 

Diese Warnmeldung kam erst wenn ich in Chrome Dirttanbieter Cookies deaktiviert hatte. Aber mit aktivierten Cookies, auch wenn ich "Alle Cookies" eingestellt hatte kam zwar die Meldung nicht, aber der GDPR Banner wurde trotzdem ständig aufgepoppt. Da hatte sich wohl was verheddert weil mit aktivierten Cookies sollte eigentlich der GDPR Banner nur 1x angezeigt werden.Bildschirmfoto 2023-08-25 um 19.40.10.png

 

Wie auch immer. Nach mehrmaligem Rumfummeln mit incognito und ein-aus-schalten gehts ja jetzt wieder wie erwartet.

Lösung in ursprünglichem Beitrag anzeigen

8 ANTWORTEN 8

Gabe
Shopify Staff
18013 2848 4193

Hey Eric! @Kummer 

 

Danke  für die Angaben und das Problem liegt nicht bei Shopify sondern bei deinem Browser. Kannst du zuerst mal deinen Browser Cache entleeren und wenn dies nicht das Problem löst, es bitte im Incognito/Private Browsing Modus nochmal probieren?

 

Außerdem empfehlen wir Safari NICHT zu verwenden falls dies der Fall sei. 😉

Gabe | Social Care @ Shopify
 - War meine Antwort hilfreich? Klicke Like um es mich wissen zu lassen! 
 - Wurde deine Frage beantwortet? Markiere es als Akzeptierte Lösung 
 - Um mehr zu erfahren, besuche das Shopify Help Center oder den Shopify Blog

rockstar3000
Entdecker
26 2 11

ich hab jetzt ein mal meinen Theme Editor im Incognito Modus geöffnet. Da erscheint dann erst mal die Meldung, dass ich Drittanbieter Cookies aktivieren soll. Seltsamerweise wurde aber auch bei neuen page load das Cookie Banner nicht angezeigt.

 

Dann hab ich den Theme Editor in einem normalen Fenster geöffnet und nun scheint der Fehler verschwunden zu sein. Sehr seltsam. Aber Fehler ist nun behoben.

Gabe
Shopify Staff
18013 2848 4193

@rockstar3000 

 

Es ist so, dass die Browser bestimmte Funktionen der Interaktivität im Browser vor allem im Theme Editor brauchen, um korrekt arbeiten zu können ansonsten looped der Browser und kommt nicht mehr weiter und man bekommt so eine Fehlermeldung.

 

Das kann vor allem im Incognito Modus passieren, also ist meine ältere Ansage von oben nicht ganz richtig, da ich das Problem nicht ganz verstanden habe. Mit deiner Korrektur unten weiss ich jetzt um was es sich handelt. Letztendlich müssen Cookies im Browser erlaubt sein so das man eine reibungslose Theme Editing Erfahrung hat:

 

image.png

 

Hier die Browser Settings (auf Englisch) die viele eingestellt haben und man dann nicht 100% auf Shopify arbeiten können:

 

image.png

Gabe | Social Care @ Shopify
 - War meine Antwort hilfreich? Klicke Like um es mich wissen zu lassen! 
 - Wurde deine Frage beantwortet? Markiere es als Akzeptierte Lösung 
 - Um mehr zu erfahren, besuche das Shopify Help Center oder den Shopify Blog

rockstar3000
Entdecker
26 2 11

Erfolg.

Ja, aber egal was ich da eingestellt hatte, mein GDPR Cookie Banner von Beeclever wurde immer angezeigt, bei jedem page reload.

 

Diese Warnmeldung kam erst wenn ich in Chrome Dirttanbieter Cookies deaktiviert hatte. Aber mit aktivierten Cookies, auch wenn ich "Alle Cookies" eingestellt hatte kam zwar die Meldung nicht, aber der GDPR Banner wurde trotzdem ständig aufgepoppt. Da hatte sich wohl was verheddert weil mit aktivierten Cookies sollte eigentlich der GDPR Banner nur 1x angezeigt werden.Bildschirmfoto 2023-08-25 um 19.40.10.png

 

Wie auch immer. Nach mehrmaligem Rumfummeln mit incognito und ein-aus-schalten gehts ja jetzt wieder wie erwartet.

PhilPruc
Shopify Partner
8 0 2

Hallo Gabe,

vielen Dank für deine Informationen.
Wieso sollte man Safari nicht nutzen?

Ich habe gerade das gleiche Problem. Ich möchte mit Safari einen Store bauen. Nach allen Schritten mit Cache und co. funktioniert es nicht. 

Kann man Safari garnicht nutzen?

Vielen Dank schonmal!

Gabe
Shopify Staff
18013 2848 4193

Hey @PhilPruc 

 

Leider sind Probleme beim Backend und Frontend Bearbeiten von Daten mit Safari weitgehend auf verschiedene SaaS Plattformen bekannt. Dafür gibt es derzeit keinen Fix ausser Apple selber behbt das Problem. 

 

Wir empfehlen Chrome, Edge und Opera.

 

VG,

Gabe | Social Care @ Shopify
 - War meine Antwort hilfreich? Klicke Like um es mich wissen zu lassen! 
 - Wurde deine Frage beantwortet? Markiere es als Akzeptierte Lösung 
 - Um mehr zu erfahren, besuche das Shopify Help Center oder den Shopify Blog

PhilPruc
Shopify Partner
8 0 2

Hey @Gabe,

okay vielen Dank!

rockstar3000
Entdecker
26 2 11

Bei mir tritt das gleiche Problem auf. Auch in Chrome. Hab das bei beiden meiner zwei Shops. Die verwenden unterschiedliche Themes und unterschiedliche GDPR Cookie Banner. 

 

Was ist die Lösung dazu?