FROM CACHE - de_header

Recaptcha wird auf Kontakt-Seite nicht angezeigt

Newster
Neues Mitglied
2 0 1

Hallo Zusammen,

 

auf meiner Kontakt-Seite wird leider kein Recaptcha gefordert (und auch das Recaptcha-Symbol unten rechts wird nicht angezeigt) - Obwohl ich "Recaptcha für Kommentar- und Kontaktformulare" in der Konfiguration eindeutig aktiviert habe.

 

Beim Registrierungsformular für Neukunden funktioniert Recaptcha hingegen einwandfrei.

 

Irgendwelche Ideen, woran es liegen könnte?

 

Herzlichen Dank vorab!

 

PS: Ich verwende das Theme "Motion". 

2 ANTWORTEN 2
Gabe
Shopify Staff
Shopify Staff
8181 1266 2109

Hey @Newster 

 

Danke für die Frage und der reCAPTCHA dient der Unterbindung der Erstellung von Fake/Bot Customer Accounts im Shop. Wenn jemand zu deinem Shop kommt und ein Konto erstellt wird die reCAPTCHA Verifizierung aktiviert, wie gesagt, so dass Bots keine Fake Accounts erstellen können (was sehr häufig heutzutage passiert).

 

Du hast also diese zwei Kästchen aktiviert und das erste Kästchen scheint nicht zu funktionieren, ist das richtig? Wie und wo genau ist deine Kontaktpage eingerichtet im "Motion" Theme? 

 

image.png

 

Meine eigenen Test in meinem Testshop haben folgendes ergeben:

 

Ich habe das jetzt in meinem eigenen Testshop getestet wo ich das reCAPTCHA Behaviour im Motion Theme mit dem im Simple Theme verglichen habe. Siehe die Ergebnisse und weiterer Ressourcen dazu unten.

 

Es hat also NICHT im Motion Theme funktioniert ABER schon im Shopify Simple Theme, wie man unten sieht. Somit ist das Problem auf das Motion Theme isoliert:

 

image.png

image.png

 

Wenn der reCAPTCHA in einem drittanbieter Theme nicht funzt dann ist möglicherweise das Motion Theme nicht richtig eingerichtet, damit reCAPTCHA da funzt -> hier wird wahrscheinlich ein Token nicht richtig für das Formular generiert und man muss das Problem im Code selber beheben. 

 

  • Dafür empfehlen wir einen Experten oder die Motion Theme Entwickler zu kontaktieren. Ggf. verlangt euer Motion Theme einen Update wie man auf dem Motion Theme Changelog verfolgen kann hier und hier können wie gesagt die Theme Entwickler helfen. 

Was ich in der Developer Console sehe:

 

image.png

image.png

 

Du kannst die folgenden Schritte befolgen, um herauszufinden, ob es sich um ein Problem mit dem Theme handelt:

 

  • Lade das betreffende Formular zusammen mit der Chrome Developer Console.
  • Öffne Inspect (Chrome Entwicklertools) und wechsle zum Reiter Netzwerk.
  • Klicke in das Formular und überprüfe in der unteren rechten Ecke deines Bildschirms, ob das reCaptcha-Logo erscheint.
  • Fülle das Formular aus und sende es ab.
  • Suche nach dem Kontakt im Netzwerk-Tab.
  • Gehe zum Abschnitt Kopfzeilen und scrolle nach unten zu Formulardaten.
  • Prüfe, ob das reCaptcha-v3-Token vorhanden ist.

Wenn kein Token vorhanden ist, ist der Fehler das erwartete Verhalten und es liegt an euch, den Theme-Code zu überprüfen. Siehe mehr dazu hier: https://shopify.dev/themes/trust-security/captcha.


Wenn das Captcha aktiviert ist (Online Store > Einstellungen), ist die Funktion nur verfügbar, wenn der {{ content_for_header }} Tag im Theme gerendert wird. Wenn der Tag in der Vorlage fehlt, wird reCAPTCHA nicht geladen.


Die reCAPTCHA-Funktionalität wird durch das Vorhandensein von Kunden-, Kontakt- und Blog-Kommentarformularen initialisiert und ausgelöst, wenn mit den Formularen interagiert wird. Diese Formulare werden anhand des action Attributs des Formulars und bestimmter input attribute identifiziert. Wenn man ein benutzerdefiniertes Formular verwendet oder das Theme Formular angepasst hat, kann es auch dazu führen, dass es nicht richtig ausgelöst wird.


Hier weitere Ressourcen zu diesem Thema:

 

Gabe | Social Care @ Shopify
 - War meine Antwort hilfreich? Klicke Like um es mich wissen zu lassen! 
 - Wurde deine Frage beantwortet? Markiere es als Akzeptierte Lösung 
 - Um mehr zu erfahren, besuche das Shopify Help Center oder den Shopify Blog

Newster
Neues Mitglied
2 0 1

Hallo Gabe,

 

herzlichen Dank für die schnelle und ausführliche Antwort! 

 

Ja, vermutlich hängt die Problematik mit dem Theme "Motion" zusammen. Auch ich konnte testen, dass es mit einem anderen Theme funktioniert.

Ich werde allerdings nun erstmal nicht weiter probieren, da ich durchaus auch erstmal auf das Recaptcha an dieser Stelle verzichten kann. 

 

Nochmal, vielen Dank für die schnelle Hilfe und - falls gefeiert - frohe Weihnachten!