FROM CACHE - es_header

El nuevo tema Dawn ¿tiene bugs?

RESUELTAS
Jasfficker
Novato(a)
31 4 5

Muy buenas, comunidad!

Esta mañana he cambiado el tema (Debut) de mi tienda de ropa por el nuevo Dawn y me he encontrado con un par de sorpresas al menos.

 

Primera sorpresa: cuando he ido a mirar una ficha de producto y he elegido una talla, el botón de compra aparece desactivado. Es imposible hacer clic sobre él. En todos y cada uno de los productos pasa eso. Súper raro!!

Segunda sorpresa: en productos donde tenemos diferentes variantes, por ejemplo de color, cuando elegías un color, la foto principal cambiaba a ese color porque así habíamos configurado el producto. Pues ahora, con Dawn, esto NO funciona tampoco.

No sé si a alguien le ha pasado algo similar, si son bugs del theme o si hay algo que al hacer el cambio de Debut a Dawn se ha perdido o desconfigurado.

 

Si alguien puede ayudarme con esto se lo agradecería.

Un saludo!

1 SOLUCIÓN ACEPTADA

Soluciones aceptadas
Jasfficker
Novato(a)
31 4 5

Éxito.

Vale. He borrado y vuelto a instalar y configurar el tema Dawn.

Ahora funciona todo correctamente salvo lo último que comentaba del pluging que tengo añadido, pero esto, siendo de un pluging ya es cosa a parte.

Gracias una vez más por la ayuda @Teo 

Doy por cerrada la discusión. 

Ver la solución en mensaje original publicado

3 RESPUESTAS 3
Teo
Shopify Staff
Shopify Staff
990 356 139

Hola, @Jasfficker:

Muchas gracias por escribirnos. Lamento escuchar que estás teniendo problemas con la configuración del nuevo tema Dawn de Shopify. Estaré encantado de poder ayudar e investigar lo sucedido con el fin de ponerle una solución a estas cuestiones que nos comentas.

En relación con la primera consulta, ¿podrías confirmarme si el botón de compra aparece en la página del producto o directamente no aparece? Te comento esto porque desde el editor de tema podrás controlar la presencia del propio botón. Desde aquí, te recomendaría dirigirte a la sección Tienda online > Temas > Dawn > Personalizar para acceder al editor del tema. Una vez ahí, en la barra superior selecciona Productos > Producto predeterminado. En el menú de la izquierda encontrarás la opción de Información del producto > Botones de compra.

Si no te aparece el bloque de botones de compra, podrás añadirlo y también podrás determinar el hecho de mostrar o no los botones de pago dinámico. Te dejo una captura de cómo se muestra:

28-09-50051-42195.png

En relación con la segunda consulta, he estado realizando varias pruebas en mi tienda de Shopify y he de confirmarte que cuando un producto tiene diferentes variantes con distintas imágenes, al seleccionar una variante concreta, se muestra como imagen principal la de dicha variante. Dicho esto, ¿podrías también confirmarme si has seguido esta guía para agregar imágenes a las variantes de tus productos?

Con todo, en caso de que todo se muestre en orden, desde aquí te recomendaría volver a instalar el tema Dawn en tu tienda y revisar si los problemas persisten. En caso de que así sea, sería de gran ayuda que me facilitases la URL de tu tienda y capturas de pantalla con dichos errores para poder replicarlos y aislarlos.

Teo | Social Care @ Shopify 
 - ¿Te resultó útil mi respuesta? Dale Me gusta para hacérmelo saber 
 - ¿Resolvimos tu pregunta? Dale a Aceptar como solución
 - Para saber más visita el Centro de ayuda de Shopify o nuestro Blog de Shopify

Jasfficker
Novato(a)
31 4 5

Muchas gracias @Teo por tu pronta respuesta.

Te cuento.

Sí se ve el botón, pero solo al cargar por primera vez la página. Si pulsas, por ejemplo, en otra talla, automáticamente se deshabilita el botón de "Agregar al carrito" y desaparece el botón "Comprar ahora". Y como verás en la imagen, si vuelvo a elegir la talla inicial, el botón no aparece tampoco. Esto no ocurre porque no haya stock del producto, que sí lo hay. Es algo muy raro.

 

Desaparición-botón-compra.jpg

 

Respecto a lo del cambio de imagen según la variante, sí está bien configurado. Ya aprendí en su día la forma correcta de hacerlo. Lo tenía ya hecho con el tema Debut y funcionaba perfectamente. Ha sido con el cambio cuando ha dejado de funcionar. En Dawn aparece la variante primera y da igual la que elijas, no cambia la imagen.

 

También ocurre otra cosa con una App que tenía instalada, que de las 2 cosas que deberían aparecer en los datos de la página de producto, solo aparece una. Todo un misterio también.

Añado captura de esto...

Desaparición-datos-pluging.jpg

 

Supongo que me tocará reinstalar el tema y comprobar si eso lo soluciona.

Muchas gracias por tu ayuda!

 

 

Jasfficker
Novato(a)
31 4 5

Éxito.

Vale. He borrado y vuelto a instalar y configurar el tema Dawn.

Ahora funciona todo correctamente salvo lo último que comentaba del pluging que tengo añadido, pero esto, siendo de un pluging ya es cosa a parte.

Gracias una vez más por la ayuda @Teo 

Doy por cerrada la discusión.