No content to show

User Activity

Ahh, didn't see your reply. I'll send you a DM.
Store is loading pretty quickly for me. Google pagespeed is flagging 2 issues related to image formats and sizes:Optimizing images and deferring 3rd party app javascript will have a noticable impact on the speed.
You can run WordPress on /blog if you use a proxy (Cloudflare or AWS Cloudfront) and host it somewhere else. You'll have a lot more options for blog customization in that case. We did something similar for https://skooncatlitter.com/blog/ where the b...
Yes, https://partners.shopify.com. You'll need to go to Apps > All apps option, then click on one app. On the next page you'll see Insights option on the left sidebar. Once you click it, it will show API health.
This might help: https://community.shopify.com/c/shopify-apps/monthly-purchase-limit-per-customer-on-shopify/m-p/2418207
You'll need to contact app developer for this. Most likely they need to reset the config on their side for the reinstall to work.
Do you have Google voice or a Google Fi phone number?
Check the partner portal > App > Insights > API health. It will show if you are making any deprecated api calls.  
Looks like a local browser issue. Does it occur if you use another browser?
To make your store fast, you can start by optimizing images. For more tips, check out https://help.shopify.com/en/manual/online-store/web-performance/improving-web-performance
If you are referring to the 30 day trial, you can cancel it anytime. 
Yes, hosting WordPress on a subdomain is safe and will not affect your Shopify store. 
You can try one of the page speed optimizer apps from the app store if you prefer a no-code option.
Do you have any optimization app installed on the store? 
My Accepted Solutions
This widget could not be displayed.
This widget could not be displayed.
This widget could not be displayed.
This widget could not be displayed.
Likes given to