Webhook products/create not firing

caioteixeira
Tourist
4 0 0

Hi there!

I've correctly configurated an webhook for the topic "products/create" using api version "2023-01" ( and others too ) but it doesn't seem to be firing. 

 

I already check the following:

  • Event topic: correctly registered.
  • Ssl certificate: correctly configurated.
  • Webhook address: ok here. ( already check if it's public too )
  • Version: tried everyone that is available.
  • Also I made a direct request via curl and it worked perfectly

Does anyone have any idea how the problem is occurring?

Replies 4 (4)

Liam
Shopify Staff
2731 299 769

Hi Caioteixeira,

 

If the request is working with curl but not via a webhook that does sound strange but there's some other ways to troubleshoot this.

 

  • Are you seeing any notifications coming in regarding webhook delivery attempts from the Shopify admin, under "Notifications" in the "Settings"?
  • Check your server logs to see if there are any incoming requests from Shopify. If you see any, check their HTTP response codes and the response body.
  • Ensure that your endpoint is correctly processing the payload that Shopify is sending. If there is an error processing the webhook payload, this could result in the webhook not appearing to fire.

Try the above and let us know if you're still running into issues and we can look deeper into this. 

 

Liam | Developer Advocate @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

caioteixeira
Tourist
4 0 0

Hi Liam, 

Thank you for your answer.
I tried what you said and:

Do you have another idea?

caioteixeira
Tourist
4 0 0

If it could help, my app id is 37690474497. Are you able to see the logs?

test1000
Shopify Partner
2 0 3

i have a same issue.
`products/create` webhooks are fired, but `404 not found` is displayed in delivery details.
`app/uninstalled` is not fired at all.
everything works fine with curl