Join us for an upcoming Shopify Partner webinar on February 27, 2024. Discover the latest Checkout Extensibility features, and deep dive on improvements to Shopify Functions and Web Pixels. Register now for either the 10am EST or 2pm EST sessions.
Solved

I cannot install my custom app on my production store after deploying it to heroku

alfredafutu
Shopify Partner
11 0 3

After building my custom app and testing it on my development store, i went ahead to deploy it to heroku. After the deployment on heroku, i generated the install link on my partners dashboard but when i try to install the app using this link i get the message in the screen shot: Screenshot 2021-11-19 at 12.40.01.png

 

I would be glad if someone points me in the right direction to solve this as i am on a tight schedule to get things up and running.

Thanks

Accepted Solution (1)
tolgapaksoy
Shopify Partner
105 7 64

This is an accepted solution.

Screenshot 2021-11-19 at 17.05.07.png

 You have a double / in your app redirect. You might have configured your Heroku App URL in your .env file with a trailing slash at the end.

View solution in original post

Replies 7 (7)

ashukasma
Shopify Partner
47 11 15

You can create another custom app and utilise same API credential into this app, It will solve your problem.

Shopify Expert - https://experts.shopify.com/lucentinnovation
alfredafutu
Shopify Partner
11 0 3

You mean to create another custom app in my partners dashboard and use the credentials of the problematic app in the new app?

tolgapaksoy
Shopify Partner
105 7 64

You need to contact the developer of this application. Your Heroku app URL needs to be whitelisted by the app developer like this:

tolgapaksoy_0-1637336996025.png

 

Your Heroku URL should be in that redirection URL whitelist.

 

alfredafutu
Shopify Partner
11 0 3

@tolgapaksoy The heroku app url is already whitelisted as seen hereScreenshot 2021-11-19 at 15.55.02.png

tolgapaksoy
Shopify Partner
105 7 64

Well something is 100% wrong in your whitelist URLs.

 

You most likely are missing the redirect:

 

https://ping-rider.herokuapp.com/shopify/auth/callback

 

tolgapaksoy
Shopify Partner
105 7 64

This is an accepted solution.

Screenshot 2021-11-19 at 17.05.07.png

 You have a double / in your app redirect. You might have configured your Heroku App URL in your .env file with a trailing slash at the end.

alfredafutu
Shopify Partner
11 0 3

@tolgapaksoy that was the issue. I configured my host url env variable with a trailing slash. You just saved me going crazy