Why isn't my new Facebook ad pixel showing as active?

Solved

Why isn't my new Facebook ad pixel showing as active?

setaz
Tourist
12 2 4

I seem to have everything set up (pixel looks active, domain is verified) and I tried creating an ad in Facebook. I chose Boost Existing Content on Facebook, and it took me to the page where I put all the configurations to boost a post. At the bottom of the page after the Total Budget, there is information about where to place the ad (FB/ Insta) and also about the pixel and the domain.

Screenshot 2023-04-24 at 9.33.48 AM.png

As you can see at the photo attached, I can only see an old pixel called Setaprint, not my newly created pixel called Seta Zakian and it says "Your Meta pixel is not active". Also at the Domain section is says "No Domain" 

I checked my domains and they seem ok

Screenshot 2023-04-24 at 9.49.38 AM.png

And I checked my pixel page and it looks like my newly created pixel is active

Screenshot 2023-04-24 at 9.41.04 AM.png

So, what I am missing? Should I connect assets to the pixels or the domains? I have no idea what to do.

Note that if I select to boost existing content on Instagram (instead of FB), there is no mention of pixel or domain on the configuration page of the ad.

Thanks

 

Accepted Solution (1)

setaz
Tourist
12 2 4

This is an accepted solution.

I actually moved my personal ad account in my business manager and connected the pixel and it looks OK now

View solution in original post

Reply 1 (1)

setaz
Tourist
12 2 4

This is an accepted solution.

I actually moved my personal ad account in my business manager and connected the pixel and it looks OK now