Join us for an upcoming Shopify Partner webinar on February 27, 2024. Discover the latest Checkout Extensibility features, and deep dive on improvements to Shopify Functions and Web Pixels. Register now for either the 10am EST or 2pm EST sessions.

"Token must be service access." error when trying to generate a storefront access token

HeroicEv
Tourist
7 1 1

I'm trying to make a post request for a storefront access token and I got this error. From looking around in the posts I see that my access token may be one of 3 different conditions, but I don't know which of them it could be. I was following the authentication tutorial in "Build a shopify app with Node and React". Could anyone let me know what the problem with my access token is? 

AppID: 4300205

StoreID: 46347124890

The access token was generated today on 10/10/2020.

 

Thank you.

Replies 4 (4)

YaketyMatt
Shopify Partner
33 0 3

Hi,

The access token is within your app. So locate the app screen in your store's dashboard and click on the link, there you should find your key/ token. Good luck, and let me know how you get on!

Matthew Anderson | Shopify Expert | +44 20 3920 8081 |  support@yakety.co.uk |  https://yakety.co.uk | Facebook | Twitter | Instagram
HeroicEv
Tourist
7 1 1

I believe that's only the case with private apps, but the one I'm making is a public one. Sorry for not mentioning that before.

YaketyMatt
Shopify Partner
33 0 3

I've just had another read of your initial question and realised that you are in fact making a request for the token.

The solution in this case:

https://community.shopify.com/c/Shopify-APIs-SDKs/Error-quot-Token-must-be-service-access-quot-when-...

..was to omit the access_token parameter when making the request. Have you done that already?

Matthew Anderson | Shopify Expert | +44 20 3920 8081 |  support@yakety.co.uk |  https://yakety.co.uk | Facebook | Twitter | Instagram
HeroicEv
Tourist
7 1 1

I have left it omitted when authenticating, but I still received the same error. I was hoping that an admin or staff could possible determine the problem like in the post you shared because nothing seems to stand out in my code.