Join us for an upcoming Shopify Partner webinar on February 27, 2024. Discover the latest Checkout Extensibility features, and deep dive on improvements to Shopify Functions and Web Pixels. Register now for either the 10am EST or 2pm EST sessions.

Languages not showing in Language Selector

ariba-s
Tourist
4 0 2

Hi,

I have English set as my default language, and I added 2 more and published them.

I'm using the Dawn 2.0 theme.

 

I added the following code to my footer section, in order to see all available languages:

 

{%- for language in localization.available_languages -%}
<p>{{ language.name }}</p>
{%- endfor -%}

 

It only returned 'English'
I also enabled the language selector and the dropdown menu only contains English.
I'm wondering why the other languages aren't shown?
Replies 6 (6)

rc28
Shopify Partner
2 0 3

I got the same issue. 

SHIBdev
Shopify Partner
334 24 92

@ariba-s  same here, just show default language.. you fixed it?

ariba-s
Tourist
4 0 2

@SHIBdev No, I haven't found a solution yet unfortunately

rc28
Shopify Partner
2 0 3

Contacted support and fixed it. What you will need to do is not only to add the language, but also select the language in the market in the setting. After you set that up, it shows more than 1 language. 

ariba-s
Tourist
4 0 2

@rc28 Would you mind sending instructions on how to do this part please?

"select the language in the market in the setting"

I would really appreciate the help!

yobaby
Visitor
1 0 1

Just figure this out. You might want to go to Setting>Markets>Manage (under Primary market)>Manage (under Domains and languages), and check the box of language that you would like to show on your website.