/fetch_stock.json api callback not updating for hourly sync

gburgoon
Tourist
19 0 2

Hi ,

 

@JamesWoo was helping me with a separate /fetch_stock issue a few months ago, but after working through that, it seems like there is another issue. 

 

When Shopify calls our /fetch_stock endpoint, it can do so in one of 2 ways.  

 

1) with SKU information (ie. fetching stock for a particular SKU)

2) without SKU information (ie. fetching stock for the entire store).  This happens every hour.

 

It appears as though 1) works fine, but 2) doesn't update any of the stock for the store.  The JSON we pass back is 100% correct (I've checked this), and I know Shopify is getting the data, because case 1) works.

 

The only other thing to note is we have some things in our warehouse that we pass back that we don't have on our Shopify store.  I'm assuming that Shopify would ignore SKUs that are returned that aren't in the store.

 

Anyone have thoughts on why 2) doesn't work?

 

Replies 11 (11)
gburgoon
Tourist
19 0 2

You don't need to select all of your products from the bulk UI, just the ones you want to sync hourly.  The rest of those products can be set to whatever app you want (I think the default is "Shopify"). As I said before *The bulk edit UI is the only place where the hourly inventory settings actually take effect*.  You mentioned "going to those products, changing the inventory managed by to the app and then checking the track quantity checkbox".  As I mentioned before, this does NOT work for hourly syncing. 

I may have misunderstood what you're saying though.  If you've also tried making these changes in the bulk UI explicitly, and you still don't see hourly syncs, then it is likely a different problem.

marcusorjames
Tourist
5 0 1

Gotcha, 

Sorry "*The bulk edit UI is the only place where the hourly inventory settings actually take effect*" is the important sentence here. I genuinely cannot believe that this would be the case and that shopify wouldn't be on this bug to fix.

I will do as you say and report back.

Thanks again for your help, and I really hope this fixes it!