keep ngrok subdomain the same when running "shopify node serve"

Solved
Colin_S
Shopify Partner
4 1 1

I purchased a ngrok plan so I can have a consistent subdomain for local development, but every time I run shopify node serve it replaces it with a new tunnel url. How can I keep this from happening? 

Surely there has to be a way to configure it to consistently use the custom ngrok subdomain. Appreciate any help with this!

Colin_S
Shopify Partner
4 1 1

Here is my Ngrok YAML configuration file

authtoken: xxxxx

tunnels:
  configurate:
    proto: http
    hostname: configurate.ngrok.io
    addr: localhost:8080

 

Not sure what settings I need to apply/change from the documentation

0 Likes
Colin_S
Shopify Partner
4 1 1

This is an accepted solution.

I was able to find a solution for anyone else that comes across this. 

you just need to run serve with the —host flag

shopify node serve --host=https://<your subdomain>.ngrok.io

 

0 Likes