Tunnel bf256c0ea7e2.ngrok.io not found

Solved
RoaldKamman
Shopify Partner
19 1 5

Hey everyone, 

 

Recently I chose to commit to learning how to create shopify apps by building one myself. 

I'm new to using ngrok and had no issues at first. But now when I run shopify serve and follow the URL I get to a blank screen with the error: 

Tunnel bf256c0ea7e2.ngrok.io not found

I have looked around and posted on their GitHub with an issue but there is no response. I have seen something about whitelisting because ngrok is supposed to generate a new URL every time it runs but I checked and the URL it keeps spinning up is the same constantly. It's also listed in my App setup url's correctly. 

 

Would really appreciate any help. I'm not ready to give up on my app idea. 

“If we can really understand the problem, the answer will come out of it, because the answer is not separate from the problem. ” ― Jiddu Krishnamurti
Replies 27 (27)
sravans
Shopify Partner
23 1 6

Thanks. This worked for me on Mac.

charcole
New Member
1 0 0

I've been having this problem as well. I learned that free ngrok urls expire, so I used `ngrok http 8081` to create a new one. and I changed .evn HOST to the new url that gave me. Didn't work. So I deleted ngrok.pid as answered above. Now I get "ngrok tunnel stopped" every time I try `shopify app serve` (the tunnel is running in another tab and didn't stop). Am I missing a step?

edit

 

edit: realized my mistake, I am not supposed to be running my own tunnel in another tab.

n8pickle
New Member
1 0 0

I recently just had this issue and all I had to do was restart the tunnel and update the url

shopify app tunnel stop
shopify app tunnel start

while starting the app with shopify app serve I selected to update the url.

This fixed it for me

sagar_at_avyya
Shopify Partner
26 1 13

@RoaldKamman Could you please change the "Accepted Solution" to this one: https://community.shopify.com/c/shopify-apis-and-sdks/tunnel-bf256c0ea7e2-ngrok-io-not-found/m-p/992...

 

Deleting the pid file works

rm ~/.cache/shopify/sv/ngrok.pid

 


Sagar @ Avyya - Modern Sales Booster
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution

den232
Shopify Partner
116 1 32

linux/windows version of the answer, (I'm on win 10) ... this from one of the comments at that youtube video.   Worked for me!

 

 Deleting the file located at "{UserName}\AppData\Local\shopify\sv" on Windows and "~/.cache/shopify/sv/ngrok.pid" on Linux is more efficient solution if anyone is experiencing this issue.

Tony49
Shopify Partner
35 2 5

What worked for me was simply running "shopify app tunnel stop", mentioned in one of the comments of this youtube video.

buildpath
Shopify Partner
56 11 17

@linen  thank you for making it easier for windows users to find and delete ngrok.pid so that ngrok starts making new tunnels again when we run shopify app serve in terminal in vscode 🙂

Ecom entrepreneur since 2004 | Shopify App developer since 2021 | Shopify merchant and theme developer since 2016
den232
Shopify Partner
116 1 32

On windows 10, I deleted the directory C:\Users\{UserName}\AppData\Local\shopify\sv 

 

I believe this worked.  Previously, I had removed/reinstalled CLI, ruby, and ngrok2 in my user folder, with no effect.  I also switched from the free ngrok to the $240/year version, all with no effect.