Re: shopify create failed to authenticate

Why does my Shopify app creation fail authentication?

Shopify Partner
24 0 11

I'm following the instructions to create a shopify app using the shopify CLI, but I get an error saying "Failed to authenticate with Shopify. Please try again later."

my-app shopify create                      
? What type of project would you like to create? (Choose with ↑ ↓ ⏎, filter with? What type of project would you like to create? (You chose: Node.js App)
? App name                                                                      
> my-app                                                                        
? What type of app are you building? (You chose: Public: An app built for a wide merchant audience.)                                                            
✗ Failed to authenticate with Shopify. Please try again later.

If I do the same by calling "shopify logout" first, in this flow I get the link to authenticate, I follow it, get the success message, but then it fails with the same message...

Anyway I can fix this?

Replies 6 (6)

Shopify Partner
835 73 176

Hi @artooras 

Hope you're having a great day!

When you create an app, it will ask you to select an organization, development store, and which type of app you’d like to make. Then, it will create your app in thePartner Dashboard for you.

Are you sure your partner dashboard account is accessible (and logged in your default browser)?

Update your Shopify App CLI, logged into your partner dashboard (in your default browser), and try again.


Useful resources:

Troubleshooting Shopify App CLI

If you're looking for a Shopify developer or just want to connect, don't hesitate to reach out!
WhatsApp: Whatsapp me!
1 0 0

Hi there,

I am facing the same issue.

Screenshot 2021-06-26 at 6.47.06 PM.png

I think this may be a Shopify CLI issue as the browser says that I am authenticated as shown in the image below. 

Screenshot 2021-06-26 at 6.48.58 PM.png

I tried this in both Google Chrome and Firefox and got the same result.

Shopify Partner
8 0 2

I have the same issue, anyone fixed it?

1 0 0

Same issue. Started to happen after upgrading to the latest CLI version. Logout and re-logging don't work. Getting authorization complete on the browser but CLI says the same error message.

Shopify Partner
8 0 2

Finally, i have my own sollution.
You just downgrade your shopify-cli to 1.13.0 and run again.

92 0 9

Why does this happen?