How to add my own video to product page (Not youtube video)

james0786
New Member
2 0 2

Hello Everyone,

 

I made a product video on my camera and now I want to add this video to my product page. I could not find a way to add the video. There is an option to add youtube video with embed code but how can I add my own video?

 

Looking forward to this problem

Replies 95 (95)
Jarv
New Member
4 0 0

Does this work if I add the code to the Image Alt text in Debutify theme ?

Tondamir
New Member
1 0 0

Hello,

i just wanted to ask that i need to make video play regurarly without clicking on the play button if it's possible.
Thanks!

CaffeVive
Tourist
8 0 2

WHY CAN'T WE JUST LINK TO SHOPIFY HOSTED VIDEOS?!?! Seems like this would be so much easier than writing code.. The video slide format is already in place on homescreen. WHy refuse shopify hosted videos? Why only FB, Vimeo??

rupert__
New Member
1 0 0

Hi Brian,

is there a way to play the video in a loop and without having to press play?

thank you.

Smeelah
Trailblazer
270 1 71

After a few hours trying unsuccessfully to add the video to my product variant photos using that tutorial, I tried Brian's code and am very happy with the option. Thanks @BrianAtWork !

I made a some adjustments to remove the border, resize it and have it autoplay and loop:


<p style="text-align: center;"><video loop="loop" muted="" autoplay="autoplay" preload="" id="vid" style="max-width: 80%; outline: none; height: auto;" outline="none">
<source src="your video file url here">
Your browser does not support our video.
</video></p>

bhammond
New Member
1 0 0

I'm added a video to my website but I'm not sure how to autoplay the video/ loop the video. Any advice? Thank you!

Smeelah
Trailblazer
270 1 71

Read the previous post lol

Fünf8
New Member
4 0 0

Bildschirmfoto 2021-01-05 um 19.00.07.png

Hey dear,

this is my solution I can not play my video what is the problem?

filmmaker123456
New Member
1 0 0

This worked for me too and looks great, but I can't get it to autoplay on Mobile. Its just chosen the first frame as the thumbnail and that's it.

Anyone got any workaround to get it autoplaying on Mobile too?

TroyNeally
Tourist
7 0 0

I am also having this same problem.  When I load the MP4 into the product media area it doesn't show up.  I did do the work around but that is ok for now, just would like to be able to add more videos to my products.

 

Regards,

Troy N.

www.JustInCaseRescue.com
Info@justincaserescue.com